1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Regular Wireless Connection Loss In XP

Discussion in 'Networking' started by mocks1, Jul 21, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. mocks1

    mocks1 Thread Starter

    Joined:
    Aug 6, 2002
    Messages:
    118
    Every few minutes the connection to the Wireless Router is lost and I have to click on the network icon in the system tray and then click the 'connect' button--then internet access is restored. The signal is showing as very strong on channel 6. What could be causing this? Is this a problem with XP networking, USB Ports, or the 2.4 GHZ frequency(i.e. microwave oven use, cordless phones) of the network? This behavior occurs using WEP and no WEP. I have not tried changing the channel or ssid yet.

    Network Specs:

    2.56 GHZ Pentium 4
    512 MB RAM
    Windows XP Professional
    Linksys wireless B Router model BEFW11S4 2.4GHZ 11 Mbs
    Linksys wireless USB adapter model wusb11 ver2.6
    Motorola Surfboard 4200 Cable Modem
    Optimum Online Broadband

    This is the only wireless adapter in the network---
    Would it be worth trading this equipment in for equipment that runs at 5 GHZ--the Linksys parts were bought two weeks ago and can still be returned.

    I have seen this same sort of intermittent connection loss behavior with a D-Link wireless USB card on a Windows XP Home system. A balloon near system tray would pop up every few minutes stating that the connection was lost . Thank you to anyone that can help me figure out the cause of these wireless problems.

    Rob
     
  2. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    I'd guess it's an interference issue, but it's only a guess. I've had pretty good luck with wireless here, but I'm not at your house. :)
     
  3. mocks1

    mocks1 Thread Starter

    Joined:
    Aug 6, 2002
    Messages:
    118
    Thanks johnwill------

    I found the following tidbits while looking for others having the same problem. I will cut and paste relevant info and provide link to original when available.

    http://www.math.uwaterloo.ca/mfcf/computing-environments/wireless/xp.html
    ------------------------------------------------------------------------------------
    Warning: Windows XP users

    --------------------------------------------------------------------------------

    We have found that Windows XP has been known to randomly drop the network connection temporarily once you have authenticated with the DHCP server/system.

    What typically happens is the XP system will randomly drop your connection after 5 to 60 minutes. We believe that this problem is due to Windows XP constantly trying to find a better source of signal from an alternate access point. We have contacted Enterasys and they are aware of the problem, but have yet to provide a working solution. The problem also occurs with other vendors of 802.11b wireless cards running under Windows XP.

    We know of only one working system configuration on campus, with Windows XP, that does not experience this problem. It is a Toshiba 6000 laptop with its own built-in wireless card.


    --------------------------------------------------------------------------------


    How can you solve the problem?
    Change your operating system to any of the following: DOS, Windows 95, Windows 2000, NT 4.0, or Linux.
    Another option is to run a kluge fix that is difficult but will work, with limitations.
    Note: It is required you have administrator privileges to the system you are on.
    Boot up your laptop and authenticate as per normal. If you are reading this page off the web, you probably have done this already
    Click on start button
    Click on control panel
    Click on administrative tools
    Click on services
    Pull the bar on right side of screen to bottom and locate "Wireless Zero Confi..."
    Click on "Wireless Zero Confi..."
    Click on the startup type button and change from automatic to manual
    Click on apply
    Click on ok
    Close the services window by clicking the X in the upper right corner
    Close the administrative tools by clicking the X in the upper right corner
    You can now use the system without being randomly disconnected however... you may lose connection from the network if you physically roam about with your laptop for any great distance and lose connection with the access points.
    If the connection is lost or if you have turned off your laptop, you will have to perform the following steps:
    Click on start button
    Click on control panel
    Click on administrative tools
    Click on services
    Pull the bar on right side of screen to bottom and locate "Wireless Zero Confi..."
    Click on "Wireless Zero Confi...
    Click on the startup type button and change from manual to automatic
    Click on apply
    Click on ok
    Close the services window by clicking the X in the upper right corner
    Close the administrative tools by clicking the X in the upper right corner
    Reboot system
    Repeat step #2 to eliminate random network disconnection

    ------------------------------------------------------------------------------------
    http://ntmain.utb.edu/wireless/default.asp?load=tech_faq#sony

    Windows XP: Wireless network adapters may lose connectivity when they appear to be functioning

    A wireless network adapter may loose its IP address and, as a result, may not have any network connectivity to access the Internet or browse the network. According to Microsoft's Online Support, this issue can occur if the SSID (Service Set Identifier) for the wireless network has not been added to the list of preferred wireless networks. This can occur if infrastructure networks are detected and wireless detection has been set to auto configuration ( the network has not been previously associated with and has not failed an 802.1x authentication attempt.)

    To resolve this issue, set the SSID of the network that you want to use from the Visible Networks list to the Preferred Networks list:

    1. In the Network Connections folder, right-click the icon for the wireless connection that you want to use, and then click Properties.
    2. Click the Wireless Networks tab, and then click Configure.
    3. In the Network Name (SSID) box, type the SSID that you want to add, and then click OK. The Wireless Network Name for UTB/TSC is LIBERTAD (all uppercase). You should should only have this wireless network name.

    ------------------------------------------------------------------------------------
    http://ntmain.utb.edu/wireless/default.asp?load=tech_faq#sony


    Windows XP Users: Wireless network connectivity problems.

    Several Windows XP users have experienced wireless network connectivity problems. To resolve the problem, make sure that you have Windows XP Service Pack 1 installed, as well as other Windows XP critical updates.
    -------------
    Unable to maintain connection to network over Roam About on Windows XP: Wireless Connectivity drops after approx. 1 min.

    The following steps have been seen to keep the client from losing wireless connectivity. As soon as connectivity is achieved, the Wireless Zero configuration service must be disabled. As soon as connectivity is achieved, go to Start/Settings/Control Panel:

    1. Click on the Administrative Tools icon, and then double-click on the Services icon.
    2. In the Services window, scroll down to the Wireless Zero configuration line and double-click on it.
    3. In the Wireless Zero Configuration Properties window that opens, click on the General Tab, and then click on the "Stop" button in the "Service Status" area.
    4. This should allow the client to retain wireless connectivity until either "goes to sleep", or is rebooted.
     
  4. niekie

    niekie

    Joined:
    Aug 1, 2003
    Messages:
    3
    I've got a trick!

    Because the XP wireless connection problem has not been solved yet, i created my own way of doing it easier. It stops the Wireless Zero Configuration Service the same way the previous post tells you about, but one doesn't have to do anything..

    - Create a .bat file with notepad:
    sc.exe stop wscsvc
    - Create a shortcut to it
    - Put it in your startup menu

    This way the service will have a chance to connect to the network while starting up, but it will stop the service right after that.
     
  5. mocks1

    mocks1 Thread Starter

    Joined:
    Aug 6, 2002
    Messages:
    118
    Thanks Niekie!

    I will make the batch file and try the fix and post back hopefully with good results.
     
  6. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Clever solution, hope it works. :)
     
  7. trypto phan

    trypto phan

    Joined:
    Aug 13, 2003
    Messages:
    1
    the bat file works, but it is:

    sc.exe stop wzcsvc

    notice the "z" not an "s" in the service name.
     
  8. albone

    albone

    Joined:
    Aug 14, 2003
    Messages:
    2
    this happened to me but when I downloaded all my updates for xp it seems like now everything is fine... except when I enable the wep key it disconects like you said every couple of minutes....

    anyone know why? I dont like leaving my wireless connection unprotected... but if I try to protect it i get disconnected everytime
     
  9. niekie

    niekie

    Joined:
    Aug 1, 2003
    Messages:
    3
    right... Wireless Zero Configuration SerViCe!
     
  10. xtnct

    xtnct

    Joined:
    Aug 26, 2003
    Messages:
    1
    I have been batteling this problem for months. I have finally found something that will help. The bat file solution above. There is nothing out there that provides the proper solution. I wonder when MS gets around to fixing this???

    Here is what I have been doing to date. The desktop bat file icons should help my process now.

    1. start computer.
    2. double click on the network icon in taskbar
    3. click advanced
    4. check ON the "Use windows to manage wireless networking"
    5. click ok
    2. connect to my network
    4. click advanced
    5. check OFF the "Use windows to manage wireless networking"
    6. close all windows.

    I would maintain the connection until the next time I use the computer, in which case I'd have to start at #1 above.
     
  11. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    If you'd like to automate your solution, check out AutoIt, it's a slick little script utility that will do mouse clicks, etc. It's also free, so it's hard not to like it. :D
     
  12. eagle_view

    eagle_view

    Joined:
    Aug 31, 2003
    Messages:
    1
    I have located a solution that fixes the problem with using the Linksys Wireless B PCMCIA Card and Linksys Router (802.11B) running under Windows XP.

    I kept getting connection losses every few minutes and would have to click on the icon on the task bar and reconnect.

    To solve this irritating problem, I simply unchecked the "Enable IEEE 802.1x authenication for this network" checkbox on the Authentication tab of the Wireless Network Properties window.
    Everything else, including 128 bit encryption and disabling of the SSID transmission were set and I haven't ecountered any problems since unchecking the checkbox.

    This may not work for everyone in all situations, but it seems to be working for my situation.

    To get to the right window, goto Control Panel, then goto Network Connections. Goto Wireless Network Connection.
    Click on Properties. Click on the Wireless Networks tab.
    Next click on Configure next to Available Networks.
    Then, click on the Authentication tab, and lastly, uncheck the "Enable IEEE 802.1x authenication for this network" checkbox. It takes a little bit to get to the correct window, but it is a one shot deal.

    Also, adding an alternate ip address (static one for my home network, eg. 192.168.1.130) in the TCP/IP properties screen for my wireless interface. Right click on the Wireless Network Connection (from Network connections window), click on Properties and with the wireless card as the interface, scroll down to "Internet Protocl (TCP/IP)" , then click on properties and goto the "Alternate Configuration Tab" and put in the correct data, ie. Static IP Address, Mask, DHCP server, DNS Servers, etc. This can be obtained from running "ipconfig /all" from a Command Prompt screen.

    Hope it helps.
     
  13. misturr50

    misturr50

    Joined:
    Aug 20, 2003
    Messages:
    2
    I promised myself if i ever fixed my wireless connection I would then help others. This is no laughing matter. Im not great at comps but I know enough. First of all dont config your wireless zero configuration what ever it is called! It wont work.
    Click on start button
    Click on control panel
    Click on administrative tools
    Click on services
    Pull the bar on right side of screen to bottom and locate "Wireless Zero Confi..."
    Click on "Wireless Zero Confi..."
    Click on the startup type button and change from automatic to manual
    Click on apply
    Click on ok
    Close the services window by clicking the X in the upper right corner
    Close the administrative tools by clicking the X in the upper right corner
    Buncha Crap if u ask me Simple to do but crap

    If you are using a Wireless B Lynksys upgrade ur firmware on ur your router enough said thats all you have to do (n) (n)
     
  14. shanster531

    shanster531

    Joined:
    Sep 12, 2003
    Messages:
    2
    I've read the posts for everyone who has XP, but i'm still using Windows ME. I think i may be having the same problem as everyone else - my wireless router/adapter, but here's what's happening with mine...

    I've been able to view websites ok, but when using AOL Instant Messenger, it shuts off and auto reconnects constantly (like every 20 min!). Even when it is working, half the time i don't get messages from other people and i can't send them.

    I don't know if this is from my wireless connection or what it is, but if anyone can help, it would be much appreciated!

    Shannon

    Email: [email protected]
     
  15. mocks1

    mocks1 Thread Starter

    Joined:
    Aug 6, 2002
    Messages:
    118
    The Batch file fix from the top of this post did indeed stop the Wireless Zero Configuration service after starting up. I applied it on My Sister's computer running XP Home at another location.

    And At Another Location:

    The Linksys router seems to be the culprit since it is also knocking out the internet connection to a computer attached via Ethernet cabling to a port. The batch file does stop the connect balloon from popping up but since both computers are affected-one wireless, one wired then it seems like it is the router--which will be returned for another one.
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/148944

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice