1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Remote Desktop turns on Laptops Num Lock - Driving me buggy

Discussion in 'Windows XP' started by StumpedTechy, Oct 21, 2005.

Thread Status:
Not open for further replies.
Advertisement
  1. StumpedTechy

    StumpedTechy Thread Starter

    Joined:
    Jul 7, 2004
    Messages:
    7,233
    Okay this is driving me nutso - I have checked the RD client on the PC side and there is nothing to turn this off anywhere...

    I have a desktop which I always have Num Lock on as it has its own dedicated keypad. The problem is when I Remote Desktop into my laptop my laptop does not have the dedicated keypad the numbers on the keypad portion are actually 1/3rd of the letters on the keyboard (I.E I,O,P would be 7,8,9) when numlock is on. It's fine until I disconnect and I go home...

    When I get home I start typing as I normally would but half the letters look like numbers because the Num Lock is still on from when I used Remote Desktop to connect in.

    I know the obvoius solution is to turn off Numlock on my PC before I disconnect Remote Desktop from the Laptop but I really just want the Laptop to revert back to its original keyboard state once I disconnect...

    Anyone know of a solution? Be kind please.
     
  2. jellygumbo

    jellygumbo

    Joined:
    Sep 2, 2003
    Messages:
    52
    Have you checked and tried to manipulate your options under the remote desktop connection / local resources?

    There is also a registry key that can be set on the laptop to make sure it doesnt turn your numlock on:

    HKEY_USERS\DEFAULT\Control Panel\Keyboard\InitialKeyboardIndicators

    Set to 0
     
  3. StumpedTechy

    StumpedTechy Thread Starter

    Joined:
    Jul 7, 2004
    Messages:
    7,233
    Hrm I'll try the reg trick see if that makes it "stick" since I don't do 10-key I never use it the local resources tab is a bust it has nothing about not passing through individual keys.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Remote Desktop turns
  1. larryh10000
    Replies:
    10
    Views:
    800
  2. chriscbp
    Replies:
    4
    Views:
    474
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/409816