Replaced DC Power Jack- Laptop still wont turn on!?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Bascotie

Thread Starter
Joined
Sep 20, 2009
Messages
301
Hi guys,

I just replaced a bad T61 power jack ( I'm sure it must've been bad since two of the wire connections came loose from the jack itself). The new power jack had all the connections to the jack just fine, so I plugged it in, connected it to mobo, put everything together and still no power.

Could it be that when the connections came loose originally the motherboard got damaged in the process? I felt almost sure it was the dc power jack as soon I saw those loose connections, but i guess not?

EDIT: To give you guys a better idea. I bought one of these: T61 DC Power Jack

I also tried plugging in the charger (which I've tested with a multimeter, and it is also a new chrarger) into the NEW port, then trying to get power from the contacts on the mobo connector (white piece in the picture). I tried pushing down with the negative connector to one of the black wire contacts, and pushing the positive tip to one of the red wire contacts and did not see any power there, so I'm wondering if I tested it wrong?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top