Replacing Compaq Presario C300 LCD Screen: blank screen now

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

cblue

Thread Starter
Joined
Sep 27, 2008
Messages
1
I have a Compaq Presario C300. Somehow the screen cracked and of course was not under warranty. I purchased a replacement screen online and followed the directions to replace. It was relatively simple, however, now when I boot up the computer, the backlight comes on for the whole screen, but shows up blank. Did I just not fully connect something? Is there something simple I can check before I bring the whole darn thing in for service anyway? This is what I was trying to avoid in the first place. The whole laptop was only 800 and the new replacement screen was $199 (as opposed to the quote for $450 I got to have it replaced).

Anyone have any ideas I can try?
 
Joined
Sep 26, 2008
Messages
176
You have to make sure you bought right screen for your laptop. Check your connection cable hasn't any damage on it. If it still shows only blank screen, i think not coming enough power for screen (wrong screen).
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top