(Resolved) All my USB Ports do not work! Help

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

computer_pet

Thread Starter
Joined
Jun 22, 2003
Messages
484
Yesterday I tried to scan a document except the scanner was not found on the PC, and was not found. I swapped USB ports except it still did not work and no sound, came through when you usally take out or put in a USB device. I few days before this my cordless mouse stopped working that is plugged into a USB port. Today I tried to plug in my Digital Camera and that also did not work.

The PC is a Compaq with Windows XP Home installed. I have four USB ports, two at front and two at back of PC. All four are not responding to any device.

I really need to use a USB port today. Can anyone help?
 

computer_pet

Thread Starter
Joined
Jun 22, 2003
Messages
484
Any help would be really great!
I need to fix this today, so any one got a solution???????
 
Joined
Feb 24, 2002
Messages
1,629
Try another USB device to confirm if the ports are functional.

Right click on MY computer (in your Start menu or desktop), select Properties - Hardware(tab) - Device manager.... locate the USB listing at the bottom of the list. Are USB HUB & hardware listed there.

- your USB maybe disabled... somehow.
- your USB ports can also be blown.
- Your USB scanner maybe dead
- your USB cable maybe damaged or dead.
 
Joined
Jun 9, 2003
Messages
8,767
C_Pet

Have you checked that the USB devices are enabled?

Could be a software glitch.

Go to "System" in Control Panel and then "Device Manager", then check to see that the USB Controller is still installed and that there are no problems.


If there are, try re-installing the USB Controller from the Compaq Restore disk.

Paq
 

computer_pet

Thread Starter
Joined
Jun 22, 2003
Messages
484
I looked at the Device Manager, and when clicking on properties of the "USB Host Controler" the computer froze.

I re-started and the USB ports are working again. Maybe it was a Software glich and needed re-starting.

Thanks
 
Joined
Jun 9, 2003
Messages
8,767
C_Pet

Sounds like it!

As a precaution, might be worth re-installing XP at some stage, just to be on the safe side!

All the best

Paq
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top