1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

[Resolved] I Explorer will not open - mfc42.dll error

Discussion in 'Earlier Versions of Windows' started by Hawkeye1068, Jan 11, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. Hawkeye1068

    Hawkeye1068 Thread Starter

    Joined:
    May 22, 2002
    Messages:
    16
    Internet Exploer terminates as soon as it opens with an error with the mfc42.dll error. I have searched the knowledge base with no solutions. I have reinstalled IE (6.0 SP1) and even recreated the dll file. The system is running ME and I tried to upgrade to XP, but the same problem occured. The biggest problem is I can't download anything (patches or upgrades) while this is happening. Any other suggestions?
     
  2. jmatt

    jmatt

    Joined:
    Apr 7, 2000
    Messages:
    844
  3. Hawkeye1068

    Hawkeye1068 Thread Starter

    Joined:
    May 22, 2002
    Messages:
    16
    I tried the comments suggested from the website, but still no luck. Sounds like it is going to have to be re-installed. Anyone else before I take the 4 hours to install?
     
  4. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    How did you "recreate" the mfc42.dll? Did you extract it from your cab files or CD? Have you ever tried using the System Restore in ME?

    Do a File search for mfc42.dll

    How many instances exist on the hard drive, what folders are they in, and what are their version numbers? You may need to Right Click on each and select Properties > Version to note them.

    There should be only one instance in windows and it should be in the c:\windows\system folder:

    http://support.microsoft.com/servicedesks/fileversion/moreinfo.asp?Id=260267

    It also looks like the mfc42.dll may be associated with spy or adware, in particular xupiter, see this thread and install Spybot if you can.

    http://forums.techguy.org/t112756/s.html

    http://tomcoyote.com/SPYBOT/

    If you are having trouble getting online, run msconfig and do a clean boot, by using the "statemgr" option on the General Page.
     
  5. Hawkeye1068

    Hawkeye1068 Thread Starter

    Joined:
    May 22, 2002
    Messages:
    16
    I ran the spybot program and deleted the AOL version of mcf42.dll and it seemed to take care of the problems. I went through and did an update for IE 6.0 and it seems to be working fine. thanks for the help
     
  6. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    Glad to hear it and you're welcome; thanks for the follow up as well.
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/112745

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice