1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

[Resolved] Photo Problem

Discussion in 'Earlier Versions of Windows' started by padutch, Nov 10, 2001.

Thread Status:
Not open for further replies.
Advertisement
  1. padutch

    padutch Thread Starter

    Joined:
    Sep 1, 2001
    Messages:
    1,297
    Running win 98 ---- I loaded MGI Photo Suite 3 ---- It took over my images. Everything I saved and opened was directed with Photo Suite. THe program is ok and I would like to keep it on here BUT I like to open my photos in IE. Went to Folder Options then to File Types to change Photo Suite to open in IE. I did this with no problem. Ha! It never fails, now when I click on a photo I get asked if I want to open or save it. THis is not on the web but from my HD. If I have a photo on my desktop and click to open it I get the save as / open -- File Download window --- Also when I do choose open it opens in my IE but with extra toolbars for editing. Never had them befor and I uncheck them they go away but the next time I open a picture they are back. I am running IE6 and no I don't want to go back to 5 because this is the first time I had a problem with 6. It usually works fine.
    THanks in advance
    Dutch
     
  2. padutch

    padutch Thread Starter

    Joined:
    Sep 1, 2001
    Messages:
    1,297
    Almost forgot. The two things I would like to do is to make windows stop using Photo Suite as the default when I save. The second is to stop windows form thinking I I am downloading the picture from the web when I am trying to open it from the desktop.
    Thanks again.
    DUTCH
     
  3. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    First try reassociating you image types by using the "right click" method. Defaults for jpegs and gif's are IExplore, and bmps, MsPaint.

    To do it this way, select (highlight) a file type, then shift+right click on it; select "open with" from the dialog and the program to open with from the scroll window. Then check "always use" and Ok.

    Also does IE6 have a "repair tool" that you can run?

    There are some registry patches for image files that you can try applying.

    You might try applying those in the image.cab file you can download here:

    http://members.home.net/winhelp98/repair98.htm
     
  4. padutch

    padutch Thread Starter

    Joined:
    Sep 1, 2001
    Messages:
    1,297
    Thanks RR the patches did the trick. Will forever be in your debt.
    DUTCH
     
  5. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    :cool: I'd seen the problem solved before (wanting to save like a web file when opened on the hard drive), but couldn't remember what the "fix" was. Maybe this time I'll remember.
     
  6. padutch

    padutch Thread Starter

    Joined:
    Sep 1, 2001
    Messages:
    1,297
    RR,
    Can I reopen this thread? Yes we solved the problem but as soon as I opened Photo Suiete again it took over again. Is there a way to stop it from taking over my jpg's ? There has to be a place to change a setting somewhere.
    DUTCH
     
  7. Mosaic1

    Mosaic1

    Joined:
    Aug 17, 2001
    Messages:
    7,486
    Use Help in the Photo suite Program. Ask about file types or File Associations.
    Most programs like that have an arean where you can check which file types to associate to it.



    that extra toolbar for editing is a feature of IE 6. TO disable it go ti Internet Options >advanced
    Scroll the Multimedai Section to>> Enable Image Toolbar. Uncheck it. Click Apply and Ok. REstart.
     
  8. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    Consider it reopened. I haven't heard of that behavior before, except when newly installing a program. Not being familiar with PhotoSuite, have you looked for anything in its options/preferences type dialogs that might make it automatically claim those extensions by default?
     
  9. padutch

    padutch Thread Starter

    Joined:
    Sep 1, 2001
    Messages:
    1,297
    Mosaic1 & RR
    Checked all the help files all the options/preferences and nothing. It just seems to want to rule. It also changes the icon I made for it back to it's standard icon. And when I right click and open as I am back to the File download window. I know it isn't a virus I am updated daily and even more and set this thing to scan for them every night. Just a precaution. Use Norton. Besides this has been ever since I loaded MGI
    Mosaic1, as for the extra toolbar I am aware of the option to turn it off but when MGI has control I disable it and it comes right back. For the short time MGI wasn't in control it works fine.
    Thanks Gentlemen and hope we can find a solution
    DUTCH
     
  10. Mosaic1

    Mosaic1

    Joined:
    Aug 17, 2001
    Messages:
    7,486
    MGI is doing that end run in the registry trick.



    It creates a new file type and name it after itself .
    Then it changes all the registered entries in
    HKEY_CLASSES_ROOT

    For instance, go to
    HKEY_CLASSES_ROOT\.gif
    look at the default value. Instead of pointing to
    giffile it is pointing at its own name.


    If you go down and look at that, you'll see the open command is for Photo Suite and that the default icon is for a Photosuite Icon too.


    It will be like that for all the file types it has taken over.


    Try this:

    Remove that entry in the registry and see if Photo suite recreates it. Do you inderstand what I mean?


    Sorry. I am tired and didn't explain too well. Get the Default filename for your Graphics files and find that in HKEY_CLASSES_ROOT

    For instance, if gif i pointing not to giffile but rather somewhere else, find that name farther Down the list.

    That is the new file type created by Photo suite.

    Remove that. REassociate your files. See if it holds. It may not. Next time you reopen Photosuite, it may recreate the File Type and do the end run again. If so, you have two choices . One is to remove Photo suite. the other is to keep it and add right click choices for the file to be opened in the program you want to use. You would right click and open with IE for example. I can help you out if you need to try that. Let me know.
     
  11. Mosaic1

    Mosaic1

    Joined:
    Aug 17, 2001
    Messages:
    7,486
    Is that a free Download? If so, I might have a look at it .
     
  12. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    What happens when you use the highlight>shift+right click method to reassociate that I explained above?

    Does it have no effect -- or it just isn't retained?
     
  13. padutch

    padutch Thread Starter

    Joined:
    Sep 1, 2001
    Messages:
    1,297
    RR it dose the same with the shift---
    Mosaic1 you hit the nail on the head ( I'm a carpenter by trade can't you tell) that is exactly what it dose. It associates itself with every pict file. When I changed them back it worked fine. As soon as I opened it again it took over again. I hate to stop using the program so will keep trying to fix this mess up. It has to be in the registry that tells everything to change wouldn't you think?
    I don't know if they have a shareware or not. Mine came with the PC
    DUTCH
    http://www.mgisoft.com/products/photosuite/index.asp is the home page
     
  14. Mosaic1

    Mosaic1

    Joined:
    Aug 17, 2001
    Messages:
    7,486
    Want to see if we can trick it?


    first step is to ad a right click menu entry to the file type it has created.

    What is the name of this new file?

    You can probably do this in Folder Options instead of opening the registry.

    See if it's in there. If it is. Double click on it.
    Look down at the big white box marked Actions.
    Click the New Button. Name the new action Open in IE.
    For the Application used to perform...
    "C:\PROGRA~1\INTERN~1\iexplore.exe" "%1"


    You can copy and paste that in if you like. Click OK
    OK again. Now right click on any of those files and Choose Open in IE. See if it works.


    Step Two:

    Go back in and in the actions box, highlight Open In IE and then click the "set aas Default" button.

    This will set Open in IE as the default action. This doesn't always work. But try it.
    Double click on a graphics file and see which program opens it.
     
  15. padutch

    padutch Thread Starter

    Joined:
    Sep 1, 2001
    Messages:
    1,297
    Mosaic1
    Had already done that with no luck.
    DUTCH
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/58153

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice