RPC and Printer Spooler Help PLEASE

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

MiRandha

Thread Starter
Joined
Mar 6, 2012
Messages
7
I am trying to re-install my printer (lexmark x2500) but I am having problems. When I go to Printers and Faxes and click on "Add Printer" I get the message "Operation could not be completed. The Printer Spooler Service is not running". I have already went into the Services and made sure that it was turned on Automatic and started it. But yet it still isn't working. Also when I plug in the USB cord for the printer into my laptop, it says down at the bottom of the screen, "Found New Hardware" but when I click on it to begin the installation, at the end it tells me "There was a problem installing this hardware. The RPC server is unavailable." I have also went into Services and made sure that the RPC was automatic and started. Still nothing. I don't understand why this is happening because in January I was able to install the printer just fine but the only mistake I made was I clicked a button that made the printer only show up as a Scanner. I have tried uninstalling the Scanner but it always shows back up once I have deleted it. Please someone help me.
 
Joined
May 22, 2005
Messages
7,091
Go to Services, look for LexBce Server, set it to Automatic and start it. Then do the same thing to Print Spooler.
 

MiRandha

Thread Starter
Joined
Mar 6, 2012
Messages
7
Thank you for your help but I could not find a LexBce Server in my service. And may I add that once I start the printer spooler, it doesn't stay that way. I have to keep starting it over.
 
Joined
May 22, 2005
Messages
7,091
Make sure both Remote Procedure Call (RPC) and DCOM Server Process Launcher are set to Automatic and started.
 
Joined
Jul 29, 2001
Messages
21,334
Have you checked the print spooler folder to see if there are any jobs stuck in there? Look in C:\windows\system32\spool\printers

If there are any files in there delete them and try to start the spooler service again.
 

MiRandha

Thread Starter
Joined
Mar 6, 2012
Messages
7
I have looked in there and there is nothing in there. I also have saw post saying to look for the LexBse Server and make sure that it is turned on, but I do not see or have a LexBse Server. Any suggestions?
 

MiRandha

Thread Starter
Joined
Mar 6, 2012
Messages
7
My dad gave me the printer two years go. No it came with no cd when he gave it to me. But I have been able to install it before. I have even went to Lexmark Website and downloaded their driver. Also a Lexmark CSR was able to get into my laptop and go through it trying to figure it out. She said it had nothing to do with the Lexmark printer. She said it was a problem with XP. Now again, I tried installing the printer in January and was able to do so but my laptop prompted me asking me a question and what ever I clicked made the printer show up as a scanner only. I have tried numerous times uninstalling the scanner but it always shows up.
 

MiRandha

Thread Starter
Joined
Mar 6, 2012
Messages
7
Okay so I gave up and thought maybe if I went and bought a new printer it would work, I was wrong. It goes all the way through the installation process and at the end says something about the RPC.... I don't understand what I need to do now. I have done everything everyone has told me to do. :(
 

MiRandha

Thread Starter
Joined
Mar 6, 2012
Messages
7
How do you fix the RPC and how to do you make the Printer Spooler stay "started"? Everytime I start it, it just stops.
 
Joined
May 22, 2005
Messages
7,091
at the end says something about the RPC.
Are you still getting "The RPC server is unavailable" message or something different. Try running these Microsoft troubleshooting programs to see if they come up with anything.

http://support.microsoft.com/mats/printing_problems/

http://windows.microsoft.com/en-us/windows/help/printer-problems-in-windows

If you still get "The RPC server is unavailable" try this:

http://support.microsoft.com/default.aspx?scid=kb;en-us;242079
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top