rpm2targz questions

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

utanja

Thread Starter
Joined
Oct 21, 2003
Messages
312
recently i was able to convert the RedHat 9 rh9.messenger.XXX.rpm to a tar.tz format and i extract all the files.....i then place the lowest level subdirectories and files in the respective Slackware 9,1 folders....

i did the install...and Yahoo Messenger works fine even thou i used the Redhat 9 rpm...

now i wish to do the same with the latesest verion of gnomeICQ.rpm....i follow the same procedure but it does not work.....any help would be appreciated... :)
 

utanja

Thread Starter
Joined
Oct 21, 2003
Messages
312
Whiteskin said:
http://www.opal.dhs.org/docs/rpm-extract.oml

Did you do that? Or was there a special tool that you used....
slackware comes with an extraction tool called rpm2targz....

i did the following...

i downloaded the RedHat9 yahoo rpm from the yahoo messenger site

then i ran rpm2targz rh9....rpm (name of the rpm file

then i expanded the gz file into its componets...

which were 2 folders ....opt and bin

then i looked into each folder and at the lowest level withched to folders respective counterparts in my linux installation....ie .../opt and /bin then i further opened each of the opt and bin folders until i get the files....and copy them into the respection directories in my linux installation....


i ran the script to install yahoo......it is /opt/bin/ymessenger yahoo/sh ymessenger

went thru the complete installation process....

it placed and incorrect launcher on my desktop ..whick i delete...and set you a new launcher pointing directed to the executible....seems to work fine....




:)
 
Joined
Nov 15, 2002
Messages
1,964
Try the rpm extract from those links. It seems to do the exact same thing, except in one step.
 

utanja

Thread Starter
Joined
Oct 21, 2003
Messages
312
Whiteskin said:
Try the rpm extract from those links. It seems to do the exact same thing, except in one step.
i will try it.....i just stumble on yesterday and decide to manually move things around...i was thinking of writing a script to do it automatically but i guess the rpm extract will also place the extracted files in proper location?... :confused:
 

utanja

Thread Starter
Joined
Oct 21, 2003
Messages
312
tnik said:
hey tonya, have you tried useing GAIM? it is a all-in-one messenger program for linux ;)

http://gaim.sf.net
i look at it and like it...but had trouble to install.....i am confused as to how to go about it....is there a binary rpm or tgz for it....i really dont understand how to compile it..
:)
 
Joined
Aug 2, 2003
Messages
735
if you go to http://gaim.sf.net/downloads.php you can get the source, then just read the INSTALL file or README on how to install it.. if I remember correctly it is just a basic ./configure, make, make install but it has been a while since I compiled it.
 
Joined
Nov 15, 2002
Messages
1,964
But if you want to use it with MSNp9 you need to install GnuTLS. Easy to get though.
 

utanja

Thread Starter
Joined
Oct 21, 2003
Messages
312
tnik said:
if you go to http://gaim.sf.net/downloads.php you can get the source, then just read the INSTALL file or README on how to install it.. if I remember correctly it is just a basic ./configure, make, make install but it has been a while since I compiled it.
kewl...i already compile it and have it running ...but cannot get into MSN....but that is ok...i dont use it much....mostly use ICQ for my european friends and yahoo for USA people....thanks so much for you suggestions... :)
 

utanja

Thread Starter
Joined
Oct 21, 2003
Messages
312
tnik said:
oh sure, us USA ppl aren't good enough for ICQ :p~

hehe jk ;)
no....not true....i just find most amerikans prefer to use yahoo aim or msn.....
:)
 
Joined
Nov 15, 2002
Messages
1,964
Its true... I think it was that we were a little disenchanted with the early interfaces.
 

utanja

Thread Starter
Joined
Oct 21, 2003
Messages
312
Whiteskin said:
But if you want to use it with MSNp9 you need to install GnuTLS. Easy to get though.
i look at GnuTLS>..and will probably install tonite...i guess i must recompile Gaim after GnuTLS installs... :confused:
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top