Runescape HD Driver fails

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Proximity

Thread Starter
Joined
Jun 1, 2009
Messages
175
First off, when i just bought my laptop last week and it came with windows XP Pro installed. Runescape HD worked fine then. I upgraded to Windows Vista Buisness edition, and thats when this problem started.

When i load runescape HD, after about 5 seconds after evreything is done loading my screen goes black for a couple seconds then comes back and a message appears saying my Display Driver has stopped responding and has recovered. Bother my java and video card drivers are up to date.

Video: ATI Mobility Radeon HD 3650
RAM:3GB
CPU: Intel(R) Core(TM)2Duo CPU P8600 @ 2.4Ghz(2CPUs), ~2.4Ghz

Any help would be appreciated. Thanks!

Edit: I guess i should add that other games work fine, like World of Warcraft.
 
Joined
Jan 10, 2005
Messages
1,705
Have you tried running the game in compatibility mode? Right click the shortcut, choose properties, compatibility.
 

Proximity

Thread Starter
Joined
Jun 1, 2009
Messages
175
Well the game runs through my internet browser, is that still possible?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top