Samsung CD-Rom sc-148c not working...

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

money_mike1978

Thread Starter
Joined
Dec 23, 2010
Messages
1
Im running a EMachine W3644 (Windows XP) with a Samsung sc-148c CD-ROM. I put a disk in and it starts to read it and the green light comes but nothing happens. Ive read all the other threads on this forum about similar issues and all the fixes did not work for me. Ive checked the device manager and it says that the hardware is working properly, which it is not. Ive added the FIXCD.REG to the registry and that did not fix it. Can someone please help me fix this thing? My wife is getting frustrated because she bought me a game for Christmas and I can not enjoy it. Please I need help.

Thanks for your time,

Michael
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top