1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

SATA HDDs not detected

Discussion in 'Hardware' started by millerhouse12, Jan 2, 2011.

Thread Status:
Not open for further replies.
  1. millerhouse12

    millerhouse12 Thread Starter

    Joined:
    Jan 2, 2011
    Messages:
    2
    Got a new PC in October and it has worked OK until a few days ago. Switched it on in the morning, booted OK. Closed it down and tried to boot up later and got a message asking for the proper boot device. Windows 7 will not load. Checked the BIOS and on the first page which lists the SATA devices, the DVD drive was listed, but neither of my HDDs showed up. However, they both were showing on the boot page. Checked Boot order was OK, but would still not load. Stuck my Windows 7 (64) CD into the DVD drive, tried a repair but didn't find an operating system. Used the Command prompt option and was able to access both Disks, so they're both working OK, but still not listed on BIOS screen. Ran a Windows start-up repair and also a CHKDSK/F on the C: drive which both appeared to find problems with file allocation tables and fixed them, but still no sign of either HDD in the SATA list and will not boot. This is an ASUS P7H57D-V EVO mobo with a 640Gb WD C: drive and a 1TB WD secondary HDD. Both connected as 6 Gb SATA drives (IDE option). 4Gb memory I really don't know where to go from here and would welcome any suggestions. I have contacted the tech support of the vendor (online company), but they don't seem to have a clue so far, so any other ideas might help.
     
  2. lewmur

    lewmur

    Joined:
    Sep 10, 2006
    Messages:
    180
    It would appear you have a hardware problem. Either the SATA controller has died or one of the drives is killing the bus. Try the drives one at a time. If that doesn't work you either have to replace the MoBo or try a PCI SATA controller.
     
  3. millerhouse12

    millerhouse12 Thread Starter

    Joined:
    Jan 2, 2011
    Messages:
    2
    I was leaning towards that conclusion myself, but vendor tech support seem convinced it's just me being stupid - I'm waiting for their next missive as they don't work weekends or Bank Holidays! The PC was twice sent out to me with the heavy caddy carrying the disks loose in the case, so I would not be surprised if the mobo or some other component has been damaged by this. I don't want to mess around with the hardware too much because of the guarantee, but might try each HDD separately as suggested - presumably I just disconnect the appropriate cable?
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/972300

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice