Says plugged in and charging, but is not charging. Just got motherboard fixed.

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Looler

Thread Starter
Joined
Apr 1, 2015
Messages
2
Hey,

I just got my computer back from having the motherboard switched out because of another problem, but now my battery will not charge. The light is on and it says it is charging, but it isn't. Should I attempt a gauge reset or something else?

It is a Lenovo y50, which I have had for 3 months. The battery needs to be unscrewed from the back.
Thanks!
 
Joined
Jun 11, 2014
Messages
2,649
First Name
Ramon
If it is not charging maybe the battery is defective.
Did they gave you back the original charger?
Did they install another different motherboard which might use a different charger?
You may need to contact the person who repaired it to find out.
 

Looler

Thread Starter
Joined
Apr 1, 2015
Messages
2
I never thought about the charger. Do different motherboards need different chargers?

P.S. Found that i charges, just up to 47%
 
Joined
Dec 5, 2013
Messages
1,768
If you have Lenovo power manager installed, check that the settings are set to fully charge vs a set parameter.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top