1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Scanner not found - Windows 98SE

Discussion in 'Earlier Versions of Windows' started by lyndros, Aug 2, 2006.

Thread Status:
Not open for further replies.
  1. lyndros

    lyndros Thread Starter

    Joined:
    Aug 2, 2006
    Messages:
    5
    I have a NEW COMPUTER (‘NC’ with USB2 ports and Windows XP) and an OLD Computer (‘OC’ with USB1 ports and Windows 98SE). They are connected to the same monitor via a Belkin Omniview KVM Switch (F1DK102uuK) which is working reasonably ok.

    The Belkin switch is connected to the OC via a USB 4 port hub. The hub is working properly, because I am able to download pictures successfully via this connection to my OC. However, I cannot get my Scanner (Packard Bell PB 61236) to work on my OC, whether it is via this connection, or directly into one of the USB ports at the rear of the computer. When I try to ‘acquire’ the scanner in my imaging software (Photo Express) the answer is always ‘scanner cannot be found, even though I know that the scanner is working because its light is on. I have tried un-installing and then re-installing the scanner driver many times but still no success.

    After I boot up OC, two problem devices always appear in the Add New Hardware Wizard –‘Unknown Device’ ‘USB Human Interface Device’

    The details of ‘Unknown Device’ are:
    Icon: Red Cross in its icon
    Device Type: Universal Serial Bus Controller
    Manufacturer: (Standard USB Host Controller)
    Hardware Version: Unknown
    Device Status: This device is disabled (Code 22). Click ‘Enable Device’ to enable this device’
    Device Usage: ‘Disable in this Hardware Profile’ is ticked but not ‘Exists in all hardware profiles’.

    No matter what route I follow (‘Search for better driver’ or ‘Display a list of all the drivers in a specific location…’ or ‘Show Compatible Hardware’) the driver I end up with is always C:\WINDOWS\INF\USB.INF. and my scanner is still not recognised. Clicking on ‘Enable Device’ seems to do nothing (no wizard appears and my screen usually freezes).

    The details of ‘USB Human Interface Device’ are:
    Icon: Yellow exclamation mark in its icon
    Device Type: Human Interface Device
    Manufacturer: (Standard Device)
    Hardware version: Not available
    Device Status: This device is either not present, not working properly or does not have all the drivers installed (Code 10). Try updating driver
    Device usage: ‘Disable in this hardware profile’ is not ticked but there is a tick in ‘Exists in all hardware profiles’

    Again no matter what route I follow the driver I end up with is always C:\WINDOWS\INF\HIDDEV.INF. I can re-install this driver from ‘Base 5.cab’, which installs successfully, and the device is then stated to be working properly, but as soon as I re-boot, it becomes a problem device again.

    Can anyone help me please. My NC is connected to the Internet, but not my OC, therefore I have to download to NC, copy to disc and install manually on my OC.

    Regards


    Lyndros
     
  2. Knotbored

    Knotbored

    Joined:
    Jun 5, 2004
    Messages:
    2,470
    I don't know all the implications of the two computer system, but perhaps the scanner requires a "powered" 4-port hub or direct connection to the USB2 computer connection.
    I gave up trying to make the cheaper "unpowered" hubs work with anything but card readers. You don't mention which is used, but if "unpowered" hub is used then try borrowing one with an electric plug connection and try it.
     
  3. lyndros

    lyndros Thread Starter

    Joined:
    Aug 2, 2006
    Messages:
    5
    I have now got the scanner to work with a very simple procedure. The key is not to install the scanner drivers with the scanner connected:
    (a) I disconnected the scanner
    (b) then I uninstalled the scanner drivers
    © then I rebooted
    (d) with the scanner still disconnected, I re-installed the scanner drivers using the software disc that came with the scanner
    (e) then I rebooted again
    (f) then I re-connected the scanner
    (g) it then worked without any problem, and there are now no problem devices appearing in my Add New Hardware Wizard

    Lyndros
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/488782

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice