screen problems on toshiba satelite 300 laptop

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Beach69

Thread Starter
Joined
Oct 21, 2009
Messages
42
This laptop is just over 1 year old and was purchased from Circuit city, We bought an extended warranty but CC is now bankrupt! I saw another post concerning a 'jumping screen' on this same model. Ours is doing the same thing. The screen does blink and shake. It gets a bunch of horizontal lines and goes white and blinks back on in rapid succession. If I were to guess I would say it is a connection issue to the monitor. ...or the monitor itself. I am an 'older' person. I am not a 'techno-geek' but I do build my own desktops mostly so I get what I want. However, laptops are whole different ballgame. We are very frustrated at this point because we feel like we need to solve this ourselves. ...and this laptop is almost new. BTW, This computer has been flawless up until now. We really are pleased with it and hope to resolve this issue. I will take the steps noted on the other thread... but? Any further input would be appreciated.

Thanks, Beach
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top