Solved Screen tinted red when charging.

Electroblob

Thread Starter
Joined
May 5, 2019
Messages
4
This is a Dell Inspiron Laptop. For some reason everyone I've seen online with similar problems has also had a Dell laptop, so it can't just be me. I've had problems with my battery and charging for a long time, and for some reason these also always seem to be correlated with other processes on my computer.

For example, in the past the computer would randomly freeze until unplugged (sometimes resulting in a crash and even software recovery). Recently, the computer gives warning messages about using the wrong AC Adapter (even though I'm using the one that came with the computer), it says that my computer isn't charging, that the battery is not operational, and sometimes it will charge slowly or just stop charging (or appear to stop charging, after I restart the computer it will have full charge.)

One time it said it could not detect the battery and showed nothing at all on my screen. I actually had to reinstall the battery to stop this, but it only worked as a temporary solution and I've gotten a lot of the "The AC Power Adapter is not recognized" messages even now. Currently, I am dealing with a related issue that occurred a year or two ago and has now come back. Whenever I plug in, after the screen lights up like normal and begins charging, a second later the screen will change to a pinkish shade. This problem disappears after I unplug.

It's honestly more annoying than anything else. I'm junk kind of sick with dealing with this cheaply made junk. Previous laptops I've bought never had problems like these and even reinstalling Windows with factory settings has done nothing to stop the issues. I have tried calibrating the color and this only makes things tint blue when I unplug. Please help.
 

Electroblob

Thread Starter
Joined
May 5, 2019
Messages
4
Update: the problem is related to the "True Color" utility on Dell Laptops. Whenever I am charging, True Color is turned on by default. This is what has lead to the annoying change in the color quality. Why this change never occurred before, I do not know. Whatever the cause, disabling True Color has stopped it. If anyone has anymore insight into this issue I would be glad to hear.
 

Electroblob

Thread Starter
Joined
May 5, 2019
Messages
4
Everything seems to back to normal, even though I still don't understand what caused the change to begin taking place. For anyone else having this problem, the best fix is this: Go to the the tray icon ^ at the bottom of the screen. Click on "True color." Click "Disable True Color." This hopefully fixes it for future readers.
 

Couriant

James
Trusted Advisor
Spam Fighter
Joined
Mar 26, 2002
Messages
37,196
Thank you for the solution! Glad you were able to fix this
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top