Solved SD card reported missing but still seems to be there

Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

cwwozniak

Chuck
Thread Starter
Moderator
Joined
Nov 28, 2005
Messages
71,932
The MicroSD card on my Moto e phone went missing this morning. I had the phone face down in do-not-disturb mode overnight. When I flipped it over in the morning I had alerts the microSD card (PNY 32GB Elite Class 10 U1) was not supported and another alert that it was missing. Shutting down and restarting two times did not change anything.

When I first installed the SD card in March 2021 it was set up as removable storage. I reconfigured it as internal storage a few months ago and everything seemed to be working fine back then. I had thought I had installed or moved a number of apps to the microSD card, but only Firefox is now shown as missing.

I removed the card and cleaned the contacts with some IPA and a cotton swab. It is still reported as missing.

Here is what I think is the weird part. I have my phone set to save camera photos to only the SD card and not use any cloud storage. I turned off data and WiFi and tried to take a picture. I got a popup error that the photo could not be saved as there was no SD card. This is what I expected. However, the phone's photo album shows all of the photos taken from when I got the phone through some taken yesterday. If the card is truly not detectable by the OS, how am I able to view the photos?

The phone shows up in Windows 10 file explorer when I connect the phone by USB to my desktop PC but does not show any folders in the phone at all.

How do I get the phone to recognize the SD card again? I don't have any spare microSD cards at the moment to test if the original card had somehow gone bad.

The OS is Android 10 Kernel version 4.9.206-perf+
 
Last edited:

cwwozniak

Chuck
Thread Starter
Moderator
Joined
Nov 28, 2005
Messages
71,932
It turned out that the microSD may actually be bad. I purchased and installed a new one. It is recognized by the phone. I will keep it as removable storage for now.

I discovered that the photos were (also?) saved in the phone's built-in 32GB memory. I had the phone forget about the old memory card and I can again take and save photos.
 
Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top