Seagate USB HDD not accessible in Windows 7

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

ModQuad

Thread Starter
Joined
Dec 27, 2012
Messages
3
Hey guys,

I have an issue with my Seagate BlackArmour external USB (500GB) HDD.

Here are some of the symptoms:

The drive typically does not show up in 'My Computer', but if it eventually does, it shows up as 'Local Disk'
Disk Management won't load whenever the drive is connected, Virtual Disk Service perpetually loads. Once I unplug the drive,

Disk management loads instantly and I get a prompt stating the drive is unformatted, asking if I'd like to format. Of course I 'cancel'.

The disk does show up in Device Manager under 'disk drives'. Any changes I make through here will freeze my PC unless I force close or unplug the drive.

The light on the drive is perpetually shining on/off gradually - there are NO clicking noises currently.

Here are some of the things I've tried:

Running "chkdsk" - command window freezes. Upon unplugging drive I get a prompt saying something like chkdsk cannot run on a drive in RAW format

I've tried 2 different machines, multiple USB ports, and 2 different known working usb cables. Same result.

I loaded Ubuntu alongside Windows 7 and the drive was recognized, I could actually see my directories/files again! I tried transferring items over to another drive and it would time out. Attempted to force mount/unmount and run an ntfs fix while in Ubuntu, it basically says the drive is corrupt and to run chkdsk.

Any ideas where to go next? Thanks in advance!
 

ModQuad

Thread Starter
Joined
Dec 27, 2012
Messages
3
Download Seatools and run the Long Generic Test.

If it fails, and is less than 5 years old, you can get a replacement.

http://www.seagate.com/support/external-hard-drives/
I've tried SeaTools but it freezes when searching for USB drives - I sat there and watched it for several minutes. The second I pull the SeaTools loads up and I get a prompt to 'format the disk', which of course I can't do because it's not inserted anymore.

The warranty replacement would be a last resort as I'm more concerned with data recovery at this point. So far my plan is to try connecting the HDD to a different USB enclosure.

Thanks for your input.
 
Joined
Nov 17, 2008
Messages
730
That is a portable. Didn't notice it at first.

I wouldn't try to remove it.

I would give Seagate a call for any advice. 1-800-seagate.

You can also go to Device Mgr and uninstall and reboot and you may have luck.

Hope it helps.

Can you hear any vibration when it is plugged in?

If not, it is probably dead. - Sorry.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top