1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Send on behalf of permissions...

Discussion in 'Business Applications' started by mcseguy9, Sep 29, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. mcseguy9

    mcseguy9 Thread Starter

    Joined:
    Jun 11, 2001
    Messages:
    387
    We are running Outlook 2000 off an Exchange 2000 server. I have someone that wants to utilize the Delegate option offered in Outlook. Everything is working fine except he would like it if email's sent on behalf of user x would say that they were sent on behalf of the user. Right now it simply appears that it was sent by the user himself. Is there a way to do this? I think I remember that this is how it was in Outlook 98. Maybe they took that out in Outlook 2000? I don't know. Any help would be great. Thanks.

    :D
     
  2. Anne Troy

    Anne Troy

    Joined:
    Feb 14, 1999
    Messages:
    11,746
    First Name:
    Anne
    And I thought that it did it that way automatically...
     
  3. top_gizmo

    top_gizmo

    Joined:
    Jun 27, 2003
    Messages:
    152
    In outlook, you have to first delegate the authority to send to that person. Then that person has to "Open Other persons mail" from the file menu, then once in that mail window, send the mail. It will then say it was sent by X on behalf of B.
     
  4. mcseguy9

    mcseguy9 Thread Starter

    Joined:
    Jun 11, 2001
    Messages:
    387
    Okay, I've done a couple of things that don't seem to be working. First let's go over the setup again.

    To test all of this out I have given Jim delegate access to my emailbox. He has the following permissions: Calendar and Tasks - Reviewer; Inbox - Editor. He has no other permissions in my emailbox.

    With these in place he has opened a new message in his Outlook, added the From: field (by going View>>From Field in the new message), entered my name in the From: field, added a subject and sent a message to an internal user, myself and an Internet email account. On none of these does it say anything about Jim having sent the email on behalf of Jon (that's me). It just shows up as being sent from me with no indication that Jim sent it at all. The only indication that he sent it is his signature that he created in Outlook.

    Another thing we tried was adding him to my Security tab in my user properties in AD Users and Computers and giving him Send As permissions there. If I open my user account in there and click the Security tab I can add Jim and check the Send As checkbox in the Allow column. Doing this did not help, either. Although he can send email's on my behalf, they still don't indicate that they were sent by Jim on my behalf. They appear as though they simply came straight from me. This last one dealing with AD Users and Computers I got from another post that had a link to a KB article that suggested this.

    I also removed him from my Security tab and added him instead to the Exchange General>>Delivery Options section of my user account in AD Users and Computers. In there you can set someone up with Send on behalf permissions. After adding him to this I clicked on the little question mark button next to the X close button at the top right of the Delivery Options window. I then clicked on Send on behalf to see what it had to say. Nowhere in that information does it say that it will say the message was sent by so and so on behalf of so and so. It gives this as an example of how it works, "A sales manager can enable a sales representative to send messages on her behalf. When messages are sent by the sales representative, they appear to be from the sales manager." It says nothing about an indicator showing that it was sent on behalf of anyone.

    Any other ideas?
     
  5. TRenyak

    TRenyak

    Joined:
    Mar 31, 2004
    Messages:
    2
    I have a user that wants to use another mailbox and make the email appear to come from that mailbox (without the on behalf of). I only have been able to make that work if I make the user a domain admin. Is there a way to do it without making the user a domain admin?

    I have Windows 2003 Server Standard, Exchange Server 2003, and the clients is Outlook 2002 and Outlook 2003.
     
  6. mcseguy9

    mcseguy9 Thread Starter

    Joined:
    Jun 11, 2001
    Messages:
    387
    One thing to try is to give the user permissions through Active Directory. Open the account of the user that needs to grant access (User A) to the other user (User B). Click the Exchange Advanced tab and add the user and give them appropriate permissions. User B should than be able to use the From field in an email and put the name of User A in there and send it and it should look like it's coming from User A. This may be considered a "loose" way to do this, but I work in a "loose" organization.
     
  7. TRenyak

    TRenyak

    Joined:
    Mar 31, 2004
    Messages:
    2
    Thank you for the reply.

    I did add the user to Exchange Advanced - Mailbox rights for the mailbox. I gave the user the same permissions - Delete, Read, Change, Take Ownership, Full Mailbox Access - that I saw Domain Admins had. But that didn't change anything until I made the user a Domain Admin.

    This wasn't a problem when I had NT 4, Exchange 5.5, and Outlook 2002/2003 but with my recent switch to Windows 2003/Exchange 2003 it has become problematic...
     
  8. flyfisher82

    flyfisher82

    Joined:
    Oct 5, 2004
    Messages:
    2
    I have the same problem since upgrading to windows/exchange 2003. In fact, I have one user that others can send as and another user that users can only send on behalf of, and all of the exchange permissions and delegate permissions are exactly the same for both. The only difference I can think of is maybe the one that works correctly had given permission before the upgrade to 2003. I think this is an exchange bug.
     
  9. flyfisher82

    flyfisher82

    Joined:
    Oct 5, 2004
    Messages:
    2
    I seem to have found the answer. It's in active directory users and computers, username, security (not exchange advanced), send as and then wait overnight for the permissions to propagate.
     
  10. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/168341

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice