Serious graphical glitch

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

CaptainWillX

Thread Starter
Joined
Mar 26, 2008
Messages
4
Hi there - I've recently been having problems with my XP installation, and it is making the screen unreadable when the glitch occurs.

I'll try to describe the problem in detail:

Sometimes when the computer has been running for a while, and especially when I am running a program which switches the screen resolution (so it would seem), the screen will suddenly go blank. Not just black blank either - the colour varies from a sludgy green to a sludgy red, but I've also seen white and black variations of the problem. I've also noticed that just before the login screen appears when I boot into XP, the screen goes to the sludgy red colour for about a second before it seems to recover. The computer does not freeze or become unresponsive - I can still shut down or restart manually using keyboard hotkeys - I just can't see anything other than a single screen of colour.

I've also been noticing other odd things. For example, when using an Internet browser the screen sometimes flickers momentarily, as if the browser window suddenly moved out of the viewable area and then back into it again.

The computer is, as far as I can tell, free from malware of any kind. I suspect that the graphics controller hardware or drivers are causing the problem, but I'm not ruling out corrupt RAM either. I remember about a year back I used to get frequent BSODs relating to the graphics drivers, but that cleared up ages ago.

Any ideas on this one?
 

CaptainWillX

Thread Starter
Joined
Mar 26, 2008
Messages
4
Yeah, I updated not that long ago - I think I have the latest driver. In case they weren't up to date I just attempted to install the latest ones again. The installer crashed half way through but I will try again.

Display adapter is the terrible Intel GMA950.

Ok, the installer for the drivers crashes every time, even after restart. I'm going to stress test the memory and see if there are any problems there.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top