1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Server 2003 intermintent shares

Discussion in 'Windows Server' started by zudjiian, Aug 7, 2012.

Thread Status:
Not open for further replies.
  1. zudjiian

    zudjiian Thread Starter

    Aug 3, 2012
    This problem has been ongoing for a while now and I could really use some help. Short story: Clients can share one minute and then they cant, and then later they can. This was not a problem 2 months ago and I have made no changes prior to the issues.
    Windows Server 2003 enterprise edition
    Active Directory
    File/Print Share
    Ip is Static
    Client is disconnect from shares (i.e. printers, shared folders, connection to the server) after being connected, especially during peak hours
    Client may be able to reconnect again without any assistance
    The shares never go down or lose complete access, only a certain amount of clients can use shares at a time and can have access.
    Client is still able to ping all machines including the server and the printers even without direct access or connection.
    Internet is 100% up and running and has no glitches on all machines.
    Server 2003 Ent. Does not limit anything according to CAL’s
    Peak hours are the worst time to connect thus implying a limit or setting is not right.
    All of this was not an issue in the month of may. The changes to since before May were small at best (i.e. a file was added to the shares etc…)
    Configuration of the switch, router and server are all at 100mbps full duplex set statically not auto
    Event logs show almost no errors, or seemingly nothing related to this
    The Tcp/ip chimney is enabled, not sure if this was fixed cause there are mixed feelings on this NIC option
    Dcdiag passes everything except the system log
    Netdiag shows nothing unusual
    Device Manager shows no errors
    Nltest is 0 0x0 Nerr_success
    Chkdsk is good
    Defrag good
    And all updates installed.
    Checked for Malware and viruses... came back clean

    Please let me know if anything else is needed
  2. srhoades


    May 15, 2003
    What about the logs on the server?
  3. zudjiian

    zudjiian Thread Starter

    Aug 3, 2012
    All the logs say everything is good except the Dns logs which gives this one

    Event Type: Error
    Event Source: DNS
    Event Category: None
    Event ID: 6702
    DNS server has updated its own host (A) records. In order to ensure that its DS-integrated peer DNS servers are able to replicate with this server, an attempt was made to update them with the new records through dynamic update. An error was encountered during this update, the record data is the error code.

    If this DNS server does not have any DS-integrated peers, then this error should be ignored.
    If this DNS server's Active Directory replication partners do not have the correct IP address(es) for this server, they will be unable to replicate with it.

    To ensure proper replication:
    1) Find this server's Active Directory replication partners that run the DNS server.
    2) Open DnsManager and connect in turn to each of the replication partners.
    3) On each server, check the host (A record) registration for THIS server.
    4) Delete any A records that do NOT correspond to IP addresses of this server.
    5) If there are no A records for this server, add at least one A record corresponding to an address on this server, that the replication partner can contact. (In other words, if there multiple IP addresses for this DNS server, add at least one that is on the same network as the Active Directory DNS server you are updating.)
    6) Note, that is not necessary to update EVERY replication partner. It is only necessary that the records are fixed up on enough replication partners so that every server that replicates with this server will receive (through replication) the new data.

    This is my only DC, AD and DNS. Which it says to ignore this error at that point
    It only pops up every so often. Sometimes its 2 days othertimes its a week.
  4. neil21stirling


    Sep 12, 2007
    Is it happening to the same client machines all the time? or is it randomly different ones throughout the network?
    Do your event logs record all events?

    From your response it does not look like this is a DNS issue, although restarting the DNS services on your server wouldn't hurt alongside your DCHP services.
    Have you tried giving the client machines experiencing this issue a static IP?

    Also if it is only happening to certain machines (ie. the same ones all the time) it may be worth checking the network cables, network points, patch panel and network switch looking at the specific ports for which computers suffering from this are connected to.
  5. zudjiian

    zudjiian Thread Starter

    Aug 3, 2012
    Thanks for the response, unfortunatly it is not happening to the same machines everytime. Some machines are more prone to it but only because those machines print more jobs. Its as if it is rechecking for creditials but cannot get through so it says unable to connect(but that is just a thought).
    I do believe that the event log is recording everything. The properties show everything being recorded and I have the usually logs, app, sec, sys, dir ser, dns ser, file rep, i.e., windows forwarding, powershell.

    I have not tried giving any of the machines a static Ip address as of yet but I will try it immediatly.
    What I did try was modifying the hosts file to include the dns server address directly. The few machines I did this two have had zero issues since but then again it has not been 24 hours yet. I am assuming this would definatly nail down the idea that it is a dns issue. The question for me, since I am not all that knowledgable with servers is, how do i track down the problem and fix it?
  6. zudjiian

    zudjiian Thread Starter

    Aug 3, 2012
    Okay I did try static ip address's on a few machines. It did not work, I had at least 2 of them not be able to reconnect. On a brighter note, machines that I changed the host file on have had zero problems.
  7. zudjiian

    zudjiian Thread Starter

    Aug 3, 2012
    Cleared the DNS cache and everything seemed to work wonderfully for over 24 hours... I am just now seeing signs of the same old problems. Its not as wide spread, but I have a feeling that is just a matter of time.
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1064189