1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved Setting up Wake on LAN - network port not powered

Discussion in 'Networking' started by ChimpanzeeUK, Apr 26, 2018.

Thread Status:
Not open for further replies.
Advertisement
  1. ChimpanzeeUK

    ChimpanzeeUK Thread Starter

    Joined:
    Jul 31, 2007
    Messages:
    100
    Hi. I'm trying to set-up WOL on my Windows 10 PC so I can turn it on remotely. I've configured my BIOS and network adapter (I believe) correctly, but my MB doesn't seem to be providing power to my network adaptor when the PC is powered off. The light on the network port doesn't blink.

    So far I have...
    1. Configured my router to forward a port (9, in my case) to my PC
    2. Set my BIOS to allow the computer to wake from PCI device
      [​IMG]
    3. Set my network adapter to wake on magic packet
      [​IMG]
      [​IMG]
    4. Tested to ensure that the packet is being sent correctly and is being received (when the PC is on)
      [​IMG]
    5. Installed the latest network adaptor drivers from Realtek
    I've read so many guides online but can't figure out what I'm doing wrong. Does anyone have any suggestions?

    Thanks
     
    Last edited: Apr 26, 2018
  2. lochlomonder

    lochlomonder

    Joined:
    Jul 24, 2015
    Messages:
    2,547
    For your network adapter, clear the check box for Allow the computer to turn off this device to save power.
     
  3. ChimpanzeeUK

    ChimpanzeeUK Thread Starter

    Joined:
    Jul 31, 2007
    Messages:
    100
    Thanks for your suggestion. I've done that now (don't know how I missed it before) but it doesn't seem to have made any difference. There were also two other power-related options on the Advanced tab, Energy Efficient Ethernet and Green Ethernet. I've disabled both of those too but still no luck :(

    Any other ideas?
     
  4. ChimpanzeeUK

    ChimpanzeeUK Thread Starter

    Joined:
    Jul 31, 2007
    Messages:
    100
    Here are the other options I have, in case anyone spots something wrong.

    [​IMG]
     
  5. Macboatmaster

    Macboatmaster Trusted Advisor Spam Fighter

    Joined:
    Jan 14, 2010
    Messages:
    21,678
    computer must be left in sleep mode for it to work when it receives the packet with its address
    It cannot work if the computer is turned off
     
  6. zx10guy

    zx10guy Trusted Advisor Spam Fighter

    Joined:
    Mar 30, 2008
    Messages:
    5,999
    Are you sure about this?

    It's been a long time since I ran any PCs with WOL configured/enabled. But both times from what I recall, I had shutdown the boxes and were able to turn them on without issue. When the motherboard and NIC are both able to support WOL with the PC shutdown, the motherboard maintains power to the NIC for it to be powered up. I had used two versions of WOL. One where the NIC and motherboard required a wire jumper connecting the two to trigger the power up sequence when the NIC received the magic packet. The other didn't require the wire jumper.
     
  7. Macboatmaster

    Macboatmaster Trusted Advisor Spam Fighter

    Joined:
    Jan 14, 2010
    Messages:
    21,678
    Perhaps you are correct
    If the computer retains power to the Network Interface Card when the computer is completely shut down then - I am sure you are correct
    My error
    If it does not then I still think it must be left in sleep mode, where it will retain power and wake fully on receipt of the magic packet

    It is also reported that network card drivers provided by Windows 10 also cause problems with WOL
    Perhaps the test is - when shutdown is LAN light still on

    Some more detail
    https://support.microsoft.com/en-us...avior-in-windows-8-windows-8-1-and-windows-10
     
    Last edited: Apr 26, 2018
  8. zx10guy

    zx10guy Trusted Advisor Spam Fighter

    Joined:
    Mar 30, 2008
    Messages:
    5,999
    I think the references to Microsoft is for WOL functionality tied to the OS/software which would make sense the PC would have to be in a sleep state. Doing it this way negates the need to configure hardware and to have hardware with WOL support.

    I can see this being the preferred mode for enterprise deployments where the IT staff would most likely have the PCs set to go to sleep after some period of inactivity to save on power. But the IT staff would utilize the WOL tied to the OS so they can do patch updates during off hours without having to walk to each computer to turn them back on or to deal with the complexities of setting up the hardware WOL.
     
  9. Macboatmaster

    Macboatmaster Trusted Advisor Spam Fighter

    Joined:
    Jan 14, 2010
    Messages:
    21,678
    Honest answer - I do not know
    However your knowledge of these matters is greater than mine
    I will watch to see how you go with sorting it out for ChimpanzeeUK and no doubt learn a little more about it
     
  10. zx10guy

    zx10guy Trusted Advisor Spam Fighter

    Joined:
    Mar 30, 2008
    Messages:
    5,999
    Again, it's been a long time since I did anything with WOL at the hardware level. I know I was able to get it working in the two scenarios I described: with and without the jumper cable between the NIC and motherboard.

    The situation I used WOL was when dial up was still viable. I used the early form of ICS tied to the modem. I had the system set up where upon boot up, the PC would automatically dial in to my dial up account and establish a connection. I would then shut down the connection and save power by issuing a remote shutdown via a utility I found. This was well before RDP was an option. This tells you how far back this was.

    Today, I've been spoiled with the servers I have in my home network. These boxes have service processors/out of band interfaces which are powered up all the time and draw minimal power. These SPs have a network port. To gain access, I just hit the IP address of the SP to launch a web browser. From there I have a ton of options to power up, power down, do a warm reset, monitor temperature/power/resource consumption, etc. I even have the option of launching a virtual console where I have KVM access remotely to the server to include being able to mount virtual media to install software or boot the server from.

    But getting back to the OP's problem, the check of if you WOL is working at the hardware level is to see if the network port of the PC is still operating with the PC shutdown. If it is not, then you have to figure out where the problem is: either the motherboard or the NIC.
     
  11. Macboatmaster

    Macboatmaster Trusted Advisor Spam Fighter

    Joined:
    Jan 14, 2010
    Messages:
    21,678
    I agree

     
  12. zx10guy

    zx10guy Trusted Advisor Spam Fighter

    Joined:
    Mar 30, 2008
    Messages:
    5,999
    (y)
     
  13. ChimpanzeeUK

    ChimpanzeeUK Thread Starter

    Joined:
    Jul 31, 2007
    Messages:
    100
    Hi. Thank you both for your help. I tried hibernating instead of a full shutdown and even then, my PC doesn't seem to be sending any power to my network adaptor. Can you think of any other settings that I can try? I'm worried the search bar in my browser is about to catch fire! Feel like I've read every forum thread on the internet at this point! :)
     
  14. Macboatmaster

    Macboatmaster Trusted Advisor Spam Fighter

    Joined:
    Jan 14, 2010
    Messages:
    21,678
    1. BIOS setting from your motherboard manual
    ▶▶Power Management Setup

    Sets system Power Management of EuP2013 and AC Power Loss behaviors. Press

    <Enter> to enter the sub-menu.

    ▶▶EuP 2013 [Disabled]


    Enables or disables the system power consumption according to EuP2013

    regulation.

    [Enabled] Optimize the system power consumption according to EuP 2013

    regulation.

    [Disabled] Disables this function.

    Note: When enabled, the system will not support S4 & S5 wake up by USB, PCI

    and PCIe devices.

    S4 is hibernation
    However disabled is default setting so unless you have changed it that is what it still should be on

    2. ALSO in BIOS
    ▶▶Realtek PCIe GBE Family Controller


    Shows driver information and configures ethernet controller parameter. Press <Enter>
    to enter the sub-menu.
    I think that in BIOS may be different from your screenshots, which appear to be from the controller via Network and connections or device manager


    3. It may also be worthwhile checking you are indeed hibernating
    https://support.microsoft.com/en-gb/help/13770/windows-shut-down-sleep-hibernate-your-pc

    4. Also as I mentioned many people have reported it to be a driver issue with Windows 10 provided driver not allowing it, if after checking both of the above, it is still no good it may be worthwhile examining this.
     
    Last edited: Apr 27, 2018
  15. jk-vulcan

    jk-vulcan

    Joined:
    Apr 27, 2018
    Messages:
    1
    I have the same exact motherboard and i experience the same issue. It seems that after a period of time the WOL stops working. If you shutdown or go to sleep and try to wake up immediately remotely, it works but after down for a period of time it won't respond. Is that the same for you?

    As for a solution, it's likely a driver or bios problem at this point because it's not settings now that i can find. I'm gonna lean toward bios.
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1209306

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice