Shared printer won;t show up on net

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

jspatz1

Thread Starter
Joined
Jan 5, 2004
Messages
18
I have an XP and two W98 computers networked on a home wired ethernet LAN. Everything about the network seemes to work fine, but I cannot get the HP printer connected to the XP machine to show up on the network. It shows up when browsing the network from the XP machine, but not from the 98 machines. I have shared the printer, I think correctly, and also selected the Win98 drivers to be available to network machines.

When I try to add a network printer on the 98 machines, the printer does not show up when browsing the network tree to select the printer. It will, however, seem to accept it if I type in its network path maunually. Then it will successfully show up as an installed printer, but print jobs error out when sent to it. Another curious symptom, the properties dialog box for this network printer (when added with the manually entered path) comes up in French on one of the 98 machines. I am wondering if it used the wrong driver version obtained from the host machine.

Any of this sound familiar to anyone? Would love some help fixing this problem.
 

jspatz1

Thread Starter
Joined
Jan 5, 2004
Messages
18
I discovered why I could not see the shared printer on the network. The network name I gave it was too long for the 98 machines. When I shortened the name, the 98 machines could see it just fine.

But I still have the problem of print jobs erroring from the 98 machines. When I install it as a network printer on the 98 machines, everything seems to go fine. I can see it loading the drivers from the host machine, and the printer appears installed and ready to go. But any print jobs from the clients give an "error printing" in the print queue and never go through.

As I mentioned before, the Properties dialogue box for this printer, as seen from the 98 clients, shows up partially in French. This gives me the hunch that something is wrong with the driver it loaded from the host. But I don;t seem to have any control over that, so how would I approach fixing it? On the host XP machine, I do have Win98 checked as an available driver to network machines (actually it and XP are checked for me and I can't change it.)

I don;t know how to go about changing the driver loaded to the client machine. If I choose "Change Driver" my printer is not on the pick list. If I choose "Have Disk", the HP disc which came with the printer is a hopeless maze of files and folders and I can't seem to find where to get the right driver.

Any ideas?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top