1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

SharedDocs cannot be accessed

Discussion in 'Networking' started by davnon, Aug 6, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. davnon

    davnon Thread Starter

    Joined:
    Jul 23, 2006
    Messages:
    62
    I had this weird problem for some time and tried everything I could think of to solve it with no results. Maybe someone out there can suggest a solution.

    I have a home network with 5 computers. For some reason the SharedDocs (C:\Documents and Settings\All Users\Documents) folder on my computer cannot be accessed from any of the other computers on the network for either reading or writing.

    I have checked and re-established all the settings of this paricular folder and also re-instated the home network settings, but whenever I try to access it from other computers I get the access denied message. Other shared folders work fine. In fact I have shared the C drive for reading and I can access it from the other computers, except when I get to any user listed in Documents and Settings (except for the default user). I must have screwed up some setting without knowing. Please help.
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,354
    First Name:
    Terry
  3. davnon

    davnon Thread Starter

    Joined:
    Jul 23, 2006
    Messages:
    62
    Thanks for the useful pointer. It worked... but not quite ...:confused:
    I have typed in the cmd window the following commands (per MS instructions):
    cd %allusersprofile%
    cacls docume~1 /T /E /G everyone:F
    Now I can see the files and folders within the SharedDocs from other computers, but when I try to open any file (PPT or WORD) from another computer -- it tells me I don't have access privileges to open the file. However, I was able to open a picture within "Shared Pictures" folder with Office Picture Manager.

    Any ideas??
     
  4. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,354
    First Name:
    Terry
    If the computer is XP Pro with Advanced File Sharing, then I guess you need to look at the file permissions.

    If XP Home or XP Pro with Simple File Sharing, starting as simply as possible, I'd right click on the folder, select 'sharing and security,' and remove sharing. Then go back and allow sharing and allow network write access. And I'd restart the PC before and after doing this. Just hoping that Windows would get bored and start behaving. :)
     
  5. davnon

    davnon Thread Starter

    Joined:
    Jul 23, 2006
    Messages:
    62
    Things have not really improved after removing and then re-instating sharing (restarting after every change). BTW, this computer is in fact XP Home.

    After the recent actions, a new folder appeared on My Network Places for all the network computers, which is named Documents (rathe than SharedDocs) pointing to the shared docs folder on my computer(C:\Documents and Settings\All Users\Documents). This is additional to the previous SharedDocs. The new folder - Documents, can now be accessed, but most of its files and subfolders cannot be accessed. In fact this is inconsistent among the computers on the network, some can access more files than others, but all subfolders are not accessible. :eek:

    I tried to change the share name on my computer (from Documents to SharedDocs), but it would not let me edit the name. This is all quite confusing. I wonder if CACLS should be used more intelligently... :confused:
     
  6. blaqDeaph

    blaqDeaph

    Joined:
    Nov 22, 2005
    Messages:
    869
    If you enable Simple File Sharing it should solve the problem.
     
  7. davnon

    davnon Thread Starter

    Joined:
    Jul 23, 2006
    Messages:
    62
    Well ... it is XP Home, so I understand it is always set on Simple File Sharing (where do you check for it in XP Home). All my other computers are XP Pro. I wonder it this has anything to do with the problem.
     
  8. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,354
    First Name:
    Terry
    "but most of its files and subfolders cannot be accessed. In fact this is inconsistent among the computers on the network, some can access more files than others, but all subfolders are not accessible."

    Random shared files/folders not seen

    8.3 naming disabled can cause random shared files/folders to not show across the network. See this to disable, but enable instead:
    http://v2.tlab404.com/articles/detail.asp?iFaq=377&iType=15

    Windows XP uses two different names for each file on your computer. One is the name that you see in explorer and in the command prompt, and the other is an MSDOS compatible 8.3 (8 character title followed by a '.' Then three more characters to indicate the type of file) name. To enable the 8.3 naming convention:

    Open REGEDIT (Start, Run, regedit)

    Navigate to :

    HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ FileSystem

    Change the value of the NtfsDisable8dot3NameCreation to '0'
     
  9. davnon

    davnon Thread Starter

    Joined:
    Jul 23, 2006
    Messages:
    62
    I suspect this is not the problem - the register value is already set to 0.

    The files and folder are shown on all network computers! but cannot be accessed consistently. For example when I double click on a WORD file, it opens MSWORD, but then displays an error message that there are no privileges to access the file. Similar things happen for PDF, XLS and PPT files (as I mentioned not necessarily from all the computers).
     
  10. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,354
    First Name:
    Terry
    If the computer with the file that results in "there are no privileges to access the file" is XP Pro with Advanced File Sharing, then I guess you need to look at the file permissions.
     
  11. blaqDeaph

    blaqDeaph

    Joined:
    Nov 22, 2005
    Messages:
    869
    If you haven't enabled "Simple File Sharing", then you need to right click on the folder, then choose security, and make sure that theres permissions to access the folder. If you're not sure then create a entry with "everyone", and give it full access.
     
  12. davnon

    davnon Thread Starter

    Joined:
    Jul 23, 2006
    Messages:
    62
    The computer where the "SharedDocs" folder is XP-Home. Only Simple File Sharing is used in this case. Right? The computers looking from the network at this folder are XP-Pro (with Simple File Sharing enabled) but that should not be relevant. Unless ... I really don't understand it.
     
  13. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,354
    First Name:
    Terry
    OK, now we understand that you have all Home or Pro with SFS. So, I can't think of anything that would cause the errors you are getting. Within a given folder, all files should get indentical treatment (in terms of access from other computers).

    But, I'm still not sure what's happening. In your post #9 the phrase "cannot be accessed consistently" is ambiguous (to me) because I can think of at least three possible meanings. I think that you've said that the files with the problem are all on the XP Home machine. My 3 interpretations of "cannot be accessed consistently":

    a. File1 and File2 are very similar; one works fine but the other gets an error;
    b. File1 can be accessed by PCa but not by PCb;
    c. File1 can sometimes be accessed OK by PCa but other times PCa gets the error message.

    Maybe it would help somebody to know which (if any) of these are true.
     
  14. davnon

    davnon Thread Starter

    Joined:
    Jul 23, 2006
    Messages:
    62
    Agreed. I was not specific enough regarding the access inconsistency. In fact, from the 3 choices (thanks for determining it so well :) ):
    a and b are true, but c is not.

    Basically, every computer behaves consistently when trying to access files and folders. However, some of the files can be accessed by one computer but not by another computer. The other inconsistency is regarding similar files. For example, some DOC files can be accessed while some others cannot.

    Finally, I did notice that all sub-folders cannot be accessed by any of the network computers except for the generic/original ones: "Shared Music" and "Shared Pictures".

    I hope I have somewhat clarified the phenomena, but I doubt that it would reduce the confusion:confused: . I wonder if there is a way to reset the whole access permissions and then set it again. Please remember that I already tried doing it, per a previous suggestion, by disabling sharing to the Shared Documents folder, restarting the computer and then enabling sharing again. This resulted in a creation of a new share name: Documents (instead of SharedDocs) and now all the network computers see both SharedDocs and Documents on my computer, although SharedDocs is completely inaccessible, while Documents has the inconsistent accessibility problems as I have described.
     
  15. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,354
    First Name:
    Terry
    I have no more ideas. Except for the "nuclear" one: reinstall windows on the XP Home machine.
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/489941

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice