1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Sharing Files on A Network

Discussion in 'Networking' started by MichaelAdams1993, Apr 9, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. MichaelAdams1993

    MichaelAdams1993 Thread Starter

    Joined:
    Aug 22, 2009
    Messages:
    74
    I have a laptop and a PC. I would like to be able to connect to the other using my internet connection (the PC is wired and the laptop is wireless). I have done it before but for some reason it is not working anymore. I have marked files on both computers to "Share on a network". Yet they do not show up in my network place. In the past I have been able to simply run (using the WIN key + R) //computername and it has asked me for a username and password. I enter them and I'm in. It doesn't work anymore saying that it cannot find the selected path or something like that. I have done it before so is there some setting I forgot to change or something I could have changed to make this no longer work? By the way, I have Win7 on my PC and WinXP on my laptop. But it worked before so I can't see this as being an issue.

    Thanks in advance for all your help!!!!!!
     
  2. Sponsor

  3. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    74,707
    Backslashes (\\), not forward (//). :)
     
  4. MichaelAdams1993

    MichaelAdams1993 Thread Starter

    Joined:
    Aug 22, 2009
    Messages:
    74
    TerryNet: I apologize but I used backslashes when I tried it, the forwardslahses where typing errors, sorry. :)

    Anyone have any ideas on how to fix my prob?
     
  5. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    74,707
    Darn, I thought we had an easy one here. :)

    My guess is a firewall on one or both machines, but here is some low level testing and trouble shooting.

    To open a Command Window: Start - Run – cmd (command in 98SE) – OK
    (if Run not on Vista’s or 7’s Start menu, just type cmd in the Search box)

    To determine a computer's IP address: open a Command Window and type
    ipconfig

    Now for some troubleshooting:

    1. On each PC open a Command window and type
    ping IPofOther (where IPofOther is the IP address of the other PC)

    Do you get Replies, or do you get packets lost?

    If you got Replies,

    2. Do the same ping except use the Computer Name of the other computer:
    ping NameOfOtherPC

    Replies or lost packets?

    If you got Replies to either or both,

    3. Then
    Start - Run - \\IPofOther - OK

    With luck after about a minute you should get an explorer window showing the other PC's shares. If not, what is the error message?
     
  6. MichaelAdams1993

    MichaelAdams1993 Thread Starter

    Joined:
    Aug 22, 2009
    Messages:
    74
    I successfully pinged each computer from the other using both the IP and then the computer name. Then I used Run with the IPofOther and it worked! Thank you so much. But from now on am I going to have to use the IP of each computer or will I be able to use the computername?
     
  7. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    74,707
    Try again

    Start - Run - \\NameOfOtherPC - OK

    If it still doesn't work, either or both directions, please tell us the error message(s) exactly. Since the ping by name worked it should work, but sometimes I think networks have their own logic system and it is not the same as ours. :)
     
  8. MichaelAdams1993

    MichaelAdams1993 Thread Starter

    Joined:
    Aug 22, 2009
    Messages:
    74
    I have tried it and it seems to be working. I agree about networks having their own logic system. They do seem to work when they want don't they :)

    Ok well I have another, issue not really a problem:

    When I try to access my PC from my laptop it asks me to log in with my username and password for that computer. However, when I try accessing my laptop from my PC it just lets me in. How can I change this so that a username and password are required to access my files on the laptop? Our home internet signal is open and I don't want people accessing my shared files without my permission.

    Thanks everyone in advance for your help!
     
  9. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    74,707
    Your wireless network should be encrypted, preferably with at least WPA-PSK, TKIP. File sharing is not the only reason to keep people off your network.

    If your laptop is XP Pro use Advanced File Sharing (turn off Simple File Sharing). If you have XP Home you are stuck with Simple File Sharing--no way to force login/password.
     
  10. MichaelAdams1993

    MichaelAdams1993 Thread Starter

    Joined:
    Aug 22, 2009
    Messages:
    74
    Where do I go to turn on Advanced File Sharing? Simple walkthrough would be GREATLY appreciated! Thanks.
     
  11. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Actually, for XP-Home or XP-Pro, you can have an automatic login by running the following command and configuring it.

    control userpasswords2
     
  12. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    74,707
    In any Windows Explorer window: Tools - Folder Options... - View tab - scroll to bottom - uncheck 'Use simple file sharing' - Apply.
     
  13. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/915877