SIM card reader malfunction?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Karinneypenny

Thread Starter
Joined
Jan 2, 2019
Messages
1
Recently got a new phone: an iphone 7. We bought it used, but typically there aren’t many issues with the phone when buying them used. Seemed fine for the first few days, but after about five days suddenly I started getting an “Invalid SIM” message, and later a “No SIM” message. We restarted the phone multiple times, checked settings for updates, took out the SIM card and put it back in, none of the solutions we found online worked. My brother put my SIM card into his phone, and it worked just fine. Then, he put his completely functional SIM card into my phone, and still got the invalid SIM message. We were going to take it to the store to get it fixed, but after about 2 days the SIM card was *magically* found, and everything worked for about a day. Then, tonight, the “No SIM card found” message made a comeback. What is the problem if anyone knows? Why is this happening, what can I do about it, and why is it going back and forth? (I also thought I should mention that I am on vacation right now so it is important for me to be able to reach my family, and without service I can’t do that)
 

Drabdr

Brad
Moderator
Joined
Nov 26, 2007
Messages
12,832
I strongly recommend you carrying it to a service center for your carrier. There are carriers all over the place, so I would find one even where you are vacationing.
 
Joined
Aug 12, 2018
Messages
110
Recently got a new phone: an iphone 7. We bought it used, but typically there aren’t many issues with the phone when buying them used. Seemed fine for the first few days, but after about five days suddenly I started getting an “Invalid SIM” message, and later a “No SIM” message. We restarted the phone multiple times, checked settings for updates, took out the SIM card and put it back in, none of the solutions we found online worked. My brother put my SIM card into his phone, and it worked just fine. Then, he put his completely functional SIM card into my phone, and still got the invalid SIM message. We were going to take it to the store to get it fixed, but after about 2 days the SIM card was *magically* found, and everything worked for about a day. Then, tonight, the “No SIM card found” message made a comeback. What is the problem if anyone knows? Why is this happening, what can I do about it, and why is it going back and forth? (I also thought I should mention that I am on vacation right now so it is important for me to be able to reach my family, and without service I can’t do that)
Have it replaced to be sure.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top