1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved Slow connection to internet No matter which browser...

Discussion in 'Web & Email' started by Rudy2206, Jun 5, 2019.

Thread Status:
Not open for further replies.
Advertisement
  1. Rudy2206

    Rudy2206 Thread Starter

    Joined:
    May 9, 2019
    Messages:
    31
    Tech Support Guy System Info Utility version 1.0.0.4
    OS Version: Microsoft Windows 10 Home, 64 bit
    Processor: Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz, Intel64 Family 6 Model 94 Stepping 3
    Processor Count: 4
    RAM: 8071 Mb
    Graphics Card: Intel(R) HD Graphics 530, 1024 Mb
    Hard Drives: C: 930 GB (846 GB Free);
    Motherboard: LENOVO, 30C7
    Antivirus: Norton Security, Enabled and Updated
    A couple of weeks ago I began noticing an increasing slow down when I try to connect to the internet. Have tried different browsers, reset my internet "stuff" and nothing changes. It can take up to 30 seconds or more to make a connection. I have been using Chrome as my primary browser. Once it finally does connect, it's as fast as ever. Maybe a firewall setting? The only browser that did make a difference was Brave. I ran across it and thought I'd give it a try. It did a marginal increase in connection time but not real impressive. Any ideas are welcome.
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    78,269
    First Name:
    Terry
    Browsers do not connect to the internet; they just use whatever network connection is already available. Most people have their computers set to connect to a network--and usually also to the internet--upon boot or awakening. If you have some different setup maybe it would help if you described it.
     
  3. Rudy2206

    Rudy2206 Thread Starter

    Joined:
    May 9, 2019
    Messages:
    31
    I just have your standard home package that is a modem, router setup. Nothing different at all. Have tried restarting both modem and router with no improvement in time it takes to connect. Spectrum is my ISP and they can't seem to find the reason for slow connection either. Once I said that I finally am connected my speeds are normal. 100mbs down and 76mbs up they sort of let me know that as far as they were concerned there was no problem. Still taking 30 seconds or more most of the time from clicking on browser icon to get my selected home page loaded. Have changed browsers and home page and there is no improvement.
     
  4. lynx1021

    lynx1021

    Joined:
    Jan 7, 2014
    Messages:
    2,370
    Can you click on your start, go to Chrome in your programs and click on that and see if it is faster? It could be Norton checking things.
     
  5. Rudy2206

    Rudy2206 Thread Starter

    Joined:
    May 9, 2019
    Messages:
    31
    Thank you lynx1021! Doing what you suggested made an immediate change. Within about three seconds my homepage loaded and things were ready to go. Is this a safe short cut? I have Norton for a reason and am wondering what if any, problems I may run into. Don't want to sacrifice safety for speed.
     
  6. lynx1021

    lynx1021

    Joined:
    Jan 7, 2014
    Messages:
    2,370
    You need to make a new short cut from the program, the old one might have gotten messed up making windows hunt for it causing it to take longer.
     
  7. Rudy2206

    Rudy2206 Thread Starter

    Joined:
    May 9, 2019
    Messages:
    31
    Done deal lynx1021. Followed your advice and everything is working fine. I just remembered that about the time this all started I installed a Chrome update. Whether that had the same effect on other browsers I can't say. Thank you for your help. Most problems I run into are simple to solve and that's why I'm here. Some solutions are so obvious I make it hard on myself overlooking the simple fix and searching for something catastrophic. Thanks again.
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1228162

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice