Slow PC and Freezing

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

breck68

Thread Starter
Joined
May 2, 2010
Messages
17
Lately I have found that my computer has very slight hesitation on basic use, but tolerable since it is so little.

During game play, I encounter extreme lag and freezing in game that can hit 3-5 secs long.

Seems to happen far worse when in fire fight where a lot of action happens.
The video card is very new, and settings are default, because I don't know enough to tweak or OC.
I checked temperature, and I was hitting 150F, and support at XFX tell me that that is perfect, and I am safe up to 190F.

Another issue is that the ATI CCC will not open. Have tried many suggestions via google with no success.

Another issue is that I am unable to access Bios. Using DEL button on restart doesn't work.
I recently updated my bios with the latest update.

Something I have noticed is that I used CPU-Z and found that my memory is only running at 400mHz, and it should be running at 1033 or at least 800, and i think this may be the cause of my lag and freezing. But I can't access bios to try to adjust.

Here's some of my setup:

Motherboard: MSI K9N2 SLI Platnium
http://www.newegg.ca/Product/Product.aspx?Item=N82E16813130161

Memory: Mushkin Enhanced Blackline 2x2GB 1066 PC2 8500
http://www.newegg.ca/Product/Product.aspx?Item=N82E16820146785

Power: Corsair 750W
http://www.newegg.ca/Product/Product.aspx?Item=N82E16817139006

Video Card: XFX ATI Radeon HD 5850 (This was a RMA replacement to an older model)
http://www.newegg.ca/Product/Product.aspx?Item=N82E16814150477

CPU: AMD Phenom 9950 Quad


If you need more info please ask.

I guess for starters, how do I up the memory Mhz to see if it improves my pc?
 
Joined
Dec 27, 2010
Messages
109
Actually, your memory has multipliers just like your processor, and CPU-z will only show you the base speed (or something like 400x2). And it's not recommended to run your memory at higher speeds (overclocking) unless you know exactly what you're doing.

ATI CCC doesn't run if you don't have some Microsoft .NET framework installed. It's been like this since ever, and just throws you some "sorry I can't run" message, lol.

What games are you trying to play? At what settings? Have you checked your processor temperatures?
 

breck68

Thread Starter
Joined
May 2, 2010
Messages
17
I don't get any message with CCC.
CP appears to fo something, but never opens.

Playing AA3 and BFBC2.
I can set the video settings at minimal or maxed, and same issue either way.
Processor temps I think hit about 110-120F area, but I can't confirm at the moment.
I didn't have the monitor open while playing last.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top