smoke came out ... help!

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

stingerash

Thread Starter
Joined
Feb 1, 2008
Messages
38
I have a gateway lap top. The top of it is a bit loose but its usually fine, I just snap it in. Anyway, about a few months ago, the battery adapter wasnt powering the computer so they sent me a new one. Ever since I got it ( a few months) it randomly starts to smell like somethings burning. And recently when it does this my computer starts to squeak kinda for lack of better wording. Anyhow, the plug is kinda loose when it goes into the computer.... A few days ago it started to really smell randomly so I took the cord out of the computer and it started sparking and the cord was REALLY HOT. It burnt me. Anyhow the computer then turned off. The next day I tried to charge it all day without the computer on. Then i turned it on, it was working fine then after an hour... low battery.. I plugged it back in and after 5 minutes it started to smell.. all the sudden smoke kept blowing out of the back and the cord was really hot again so I turned it off. When I turn it on for a second, it seems to blow a lot of hot air out of the back but the computer itself doesnt seem too hot or anything. What should I do ? Any Advice as to what it is?? Sorry I dont know much about computers! Any help is really appreciated!!
A bit of an update... So when trying to plug the new adapter they gave me into the computer.... it immediately starts to make spark sounds and blow smoke.... so i tried taping the old adapter since the wires were starting to fray... and this one works a bit... but still smells like smoke... when all is plugged in and i can turn it on and its working, the computer seems fine. is there anyway to check through my computer of whats wrong... ex . diagnostics tool? thanks please help!!
 
Joined
Sep 20, 2007
Messages
833
Get it PROFESSIONALLY serviced without delay - and in the meantime put it somewhere where it can't possibly start a fire.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top