1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Actiontec GT701 and DLink DI-624 revC

Discussion in 'Networking' started by tk_, Jan 23, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. tk_

    tk_ Thread Starter

    Joined:
    Jan 23, 2007
    Messages:
    5
    Hello,
    Noob to the forum, but not to computers.

    I have a small home network using a DLink DI-624 (rev C if you want to get technical --haha). My main PC, which is running XP Pro SP2, is wired to one of the LAN ports on the router. I only use the wireless on occasion for my laptop.

    I finally just moved up to the 21st century and signed up for DSL. I now have an Actiontec GT701 DSL modem (this is the one that is NOT wireless --didn't figure I needed another AP since my DLink does that just fine).

    So, as per the DSL setup instructions, I took my router out of the mix, and plugged the Actiontec modem directly into my PC using an ethernet cable. I'm now on the Internet, everything is hunky-dory.

    Here is the problem: I want to get back to having my network so I want to put my DLink router between my main PC and the DSL modem. In otherwords, I want to plug the modem and my PC into the router.
    The instructions for the router say to plug the broadband (DSL modem) into the WAN port on the router, and plug the PC into one of the LAN ports. I've done this but now I can no longer get to the Internet. By the way, I had previously changed the IP of my router from the default, otherwise it would have had a conflict with the modem.

    If I plug the modem into one of the LAN ports, I can get to the Internet. If I move it to the WAN port where I believe it is supposed to be, I get nothing.
    With the modem plugged into the WAN port on the router, I can ping the router, but not the modem. It's as if my router is not letting the WAN and LAN ports play together.

    Firmware on the modem and router have been updated to the latest.

    Anyone have any ideas? Did I leave anything out?

    Thanks in advance,
    tk
     
  2. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Connecting two SOHO broadband routers together.

    Configure the IP address of the secondary router to be in the same subnet as the primary router, but out of the range of the DHCP server in the primary router. For instance DHCP server addresses 192.168.0.2 through 192.168.0.100, I'd assign the secondary router 192.168.0.254 as it's IP address.

    Disable the DHCP server in the secondary router.

    Setup the wireless section just the way you would if it was the primary router.

    Connect from the primary router's LAN port to one of the LAN ports on the secondary router. If there is no uplink port and neither of the routers have auto-sensing ports, use a cross-over cable. Leave the WAN port unconnected!
     
  3. tk_

    tk_ Thread Starter

    Joined:
    Jan 23, 2007
    Messages:
    5
    John,
    Thanks for the reply.

    I forgot to mention I don't use DHCP, I assign static IPs, so the DHCP range is not of concern.

    The IP of the modem on the LAN side is 192.168.0.1, the IP on the router is 192.168.0.5 on the LAN side and I went ahead and configured a static IP for the WAN side of the router to 192.168.0.4. As you can see, all are on the same subnet, so I'm not trying to jump networks.

    The wireless is actually already set up, just disabled until I need it.


    Now, taking from the rest of your reply, it sounds like I shouldn't even be trying to use the WAN port of my DLink router, I should just plug the LAN from the DSL modem to the LAN of the DLink router and run with it?
    "Leave the WAN port unconnected!" I guess that's the answer, right?

    Thanks again,
    tk
    p.s. the DLink has auto-sensing ports, so cross-over or straight cables are automagically handled.
     
  4. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Yep, and make sure to disable the DHCP server on the D-Link router too. :)
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/537735

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice