1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: ASIO4ALL & Debut "stdriver.sys" Conflict

Discussion in 'Windows 7' started by Wimalaya, Dec 27, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. Wimalaya

    Wimalaya Thread Starter

    Joined:
    Dec 22, 2011
    Messages:
    199
    hi,

    i have a problem with the ASIO4ALL driver i use for Ableton Live.

    When i open Ableton it immediatly bluescreens. Then after reboot, the program can open but the audio driver is turned off. When i click to select the ASIO driver in the menu, it goes to blue screen again.

    never had that problem before.
    i think its maybe the ZoomPlayer i installed recently... it had an option to install missing drivers, witch i did, so i guess it messed with the audio driver :/

    i dont know what to do to change to previous driver settings.


    Microsoft Windows 7 Home Premium
    Toshiba Satellite c660D
    x-64-based


    Here is one of the bluescreen logs:

    Problem signature:
    Problem Event Name: BlueScreen
    OS Version: 6.1.7601.2.1.0.768.3
    Locale ID: 2067

    Additional information about the problem:
    BCCode: 50
    BCP1: FFFFF880096EC008
    BCP2: 0000000000000000
    BCP3: FFFFF880062DBD25
    BCP4: 0000000000000000
    OS Version: 6_1_7601
    Service Pack: 1_0
    Product: 768_1

    Files that help describe the problem:
    C:\Windows\Minidump\122612-30576-01.dmp
    C:\Windows\temp\WER-63898-0.sysdata.xml

    Read our privacy statement online:
    http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
    C:\Windows\system32\en-US\erofflps.txt
    -------------------------------------------------------------------------------------



    thanks for the help


    EDIT: all other audio works fine btw..
     
  2. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,613
    Go to C:\Windows\Minidump and copy the file\files there to a folder on the desktop. Compress and upload for review. Did this start happening when you install ZoomPlayer?
     
  3. Wimalaya

    Wimalaya Thread Starter

    Joined:
    Dec 22, 2011
    Messages:
    199
    yes i think its the ZoomPlayer. magic dvd ripper is also installed a few days ago.
    i also checked out 2 other programs recently but uninstalled them again. dont remember the names. avi splitter was one of them.

    and yes, since then i have this issue. even the day before i was recording something and everything was fine...
     

    Attached Files:

  4. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,613
    The problem files are "stdriver64.sys" From a company called NCH Software Have you install anything from them? And the other is "live 8.2.2.exe" From Ableton "stdriver64.sys" is the main responsible file and is in conflict with "live 8.2.2.exe" We need to know if you installed anything from NCH Software.


    PHP:
    Microsoft (RWindows Debugger Version 6.12.0002.633 X86
    Copyright 
    (cMicrosoft CorporationAll rights reserved.


    Loading Dump File [C:\Users\LG-PC7\Desktop\minidump\122712-71011-01.dmp]
    Mini Kernel Dump FileOnly registers and stack trace are available

    Symbol search path is
    SRV*your local folder for symbols*http://msdl.microsoft.com/download/symbols
    Executable search path is
    Windows 7 Kernel Version 7601 (Service Pack 1MP (2 procsFree x64
    Product
    WinNtsuiteTerminalServer SingleUserTS Personal
    Built by
    7601.17944.amd64fre.win7sp1_gdr.120830-0333
    Machine Name
    :
    Kernel base 0xfffff800`01e14000 PsLoadedModuleList = 0xfffff800`02058670
    Debug session time
    Thu Dec 27 09:05:54.446 2012 (UTC 8:00)
    System Uptime0 days 23:18:13.946
    Loading Kernel Symbols
    ...............................................................
    ................................................................
    ........................................
    Loading User Symbols
    Loading unloaded module 
    list
    .......................
    *******************************************************************************
    *                                                                             *
    *                        
    Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************

    Use !
    analyze -v to get detailed debugging information.

    BugCheck 50, {fffff880094ba0001fffff880063724340}

    Unable to load image \SystemRoot\system32\DRIVERS\stdriver64.sysWin32 error 0n2
    *** WARNINGUnable to verify timestamp for stdriver64.sys
    *** ERRORModule load completed but symbols could not be loaded for stdriver64.sys

    Could not read faulting driver name
    Probably caused by 
    stdriver64.sys stdriver64+6434 )

    FollowupMachineOwner
    ---------

    0kd> !analyze -v
    *******************************************************************************
    *                                                                             *
    *                        
    Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************

    PAGE_FAULT_IN_NONPAGED_AREA (50)
    Invalid system memory was referenced.  This cannot be protected by try-except,
    it must be protected by a Probe.  Typically the address is just plain bad or it
    is pointing at freed memory
    .
    Arguments:
    Arg1fffff880094ba000memory referenced.
    Arg20000000000000001value 0 read operationwrite operation.
    Arg3fffff88006372434, If non-zerothe instruction address which referenced the bad memory
        address
    .
    Arg40000000000000000, (reserved)

    Debugging Details:
    ------------------


    Could not read faulting driver name

    WRITE_ADDRESS
    GetPointerFromAddressunable to read from fffff800020c2100
     fffff880094ba000 

    FAULTING_IP

    stdriver64+6434
    fffff880
    `06372434 f3aa            rep stos byte ptr [rdi]

    MM_INTERNAL_CODE:  0

    CUSTOMER_CRASH_COUNT:  1

    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

    BUGCHECK_STR:  0x50

    PROCESS_NAME:  Live 8.2.2.exe

    CURRENT_IRQL:  0

    TRAP_FRAME:  fffff8800ade83f0 -- (.trap 0xfffff8800ade83f0)
    NOTE: The trap frame does not contain all registers.
    Some register values may be zeroed or incorrect.
    rax=0000000000000000 rbx=0000000000000000 rcx=0000000000005000
    rdx=0000000001388000 rsi=0000000000000000 rdi=0000000000000000
    rip=fffff88006372434 rsp=fffff8800ade8580 rbp=0000000000000000
     r8=0000000000000000  r9=0000000000000000 r10=fffffa800452e1a0
    r11=fffffa80025e81c0 r12=0000000000000000 r13=0000000000000000
    r14=0000000000000000 r15=0000000000000000
    iopl=0         nv up ei pl zr na po nc
    stdriver64+0x6434:
    fffff880
    `06372434 f3aa            rep stos byte ptr [rdi]
    Resetting default scope

    LAST_CONTROL_TRANSFER
    :  from fffff80001e3aeec to fffff80001e92fc0

    STACK_TEXT
    :  
    fffff880`0ade8288 fffff800`01e3aeec 00000000`00000050 fffff880`094ba000 00000000`00000001 fffff880`0ade83f0 nt!KeBugCheckEx
    fffff880
    `0ade8290 fffff800`01e910ee 00000000`00000001 fffff880`094ba000 fffffa80`0249dc00 fffffa80`0249de93 nt! ?? ::FNODOBFM::`string'+0x4514f
    fffff880
    `0ade83f0 fffff880`06372434 : fffffa80`025e81d5 fffffa80`06e80b20 fffffa80`04529bf8 fffffa80`04532101 : nt!KiPageFault+0x16e
    fffff880
    `0ade8580 fffffa80`025e81d5 : fffffa80`06e80b20 fffffa80`04529bf8 fffffa80`04532101 fffffa80`0249dc10 : stdriver64+0x6434
    fffff880
    `0ade8588 fffffa80`06e80b20 : fffffa80`04529bf8 fffffa80`04532101 fffffa80`0249dc10 fffff880`0637658d : 0xfffffa80`025e81d5
    fffff880
    `0ade8590 fffffa80`04529bf8 fffffa80`04532101 fffffa80`0249dc10 fffff880`0637658d fffffa80`025e81c0 0xfffffa80`06e80b20
    fffff880
    `0ade8598 fffffa80`04532101 : fffffa80`0249dc10 fffff880`0637658d fffffa80`025e81c0 fffffa80`00000003 : 0xfffffa80`04529bf8
    fffff880
    `0ade85a0 fffffa80`0249dc10 fffff880`0637658d fffffa80`025e81c0 fffffa80`00000003 fffffa80`0249dc10 0xfffffa80`04532101
    fffff880
    `0ade85a8 fffff880`0637658d : fffffa80`025e81c0 fffffa80`00000003 fffffa80`0249dc10 fffff880`0636d07d : 0xfffffa80`0249dc10
    fffff880
    `0ade85b0 fffffa80`025e81c0 fffffa80`00000003 fffffa80`0249dc10 fffff880`0636d07d 00000000`0dcdfec4 stdriver64+0xa58d
    fffff880
    `0ade85b8 fffffa80`00000003 fffffa80`0249dc10 fffff880`0636d07d 00000000`0dcdfec4 00000000`0dcdfec4 0xfffffa80`025e81c0
    fffff880
    `0ade85c0 fffffa80`0249dc10 : fffff880`0636d07d 00000000`0dcdfec4 00000000`0dcdfec4 fffffa80`025e81c0 : 0xfffffa80`00000003
    fffff880
    `0ade85c8 fffff880`0636d07d 00000000`0dcdfec4 00000000`0dcdfec4 fffffa80`025e81c0 fffffa80`07417170 0xfffffa80`0249dc10
    fffff880
    `0ade85d0 00000000`0dcdfec4 : 00000000`0dcdfec4 fffffa80`025e81c0 fffffa80`07417170 00000000`00000000 : stdriver64+0x107d
    fffff880
    `0ade85d8 00000000`0dcdfec4 : fffffa80`025e81c0 fffffa80`07417170 00000000`00000000 fffff880`0636ea54 : 0xdcdfec4
    fffff880
    `0ade85e0 fffffa80`025e81c0 : fffffa80`07417170 00000000`00000000 fffff880`0636ea54 fffffa80`04529bd0 : 0xdcdfec4
    fffff880
    `0ade85e8 fffffa80`07417170 : 00000000`00000000 fffff880`0636ea54 fffffa80`04529bd0 fffff880`0ade8628 : 0xfffffa80`025e81c0
    fffff880
    `0ade85f0 00000000`00000000 fffff880`0636ea54 fffffa80`04529bd0 fffff880`0ade8628 fffffa80`00000000 0xfffffa80`07417170


    STACK_COMMAND:  kb

    FOLLOWUP_IP: 
    stdriver64+6434
    fffff880
    `06372434 f3aa            rep stos byte ptr [rdi]

    SYMBOL_STACK_INDEX:  3

    SYMBOL_NAME
    :  stdriver64+6434

    FOLLOWUP_NAME
    :  MachineOwner

    MODULE_NAME
    stdriver64

    IMAGE_NAME
    :  stdriver64.sys

    DEBUG_FLR_IMAGE_TIMESTAMP
    :  4d82a4a9

    FAILURE_BUCKET_ID
    :  X64_0x50_stdriver64+6434

    BUCKET_ID
    :  X64_0x50_stdriver64+6434

    Followup
    MachineOwner
    ---------

     
  5. Wimalaya

    Wimalaya Thread Starter

    Joined:
    Dec 22, 2011
    Messages:
    199
    ah , yes i have. its Debut Video Capture Software Professional v 1.61

    also recently installed
     
  6. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,613
    Lets uninstall that and see if the issue is resolved. To uninstall it I recommend Revo Uninstaller Freeware version it'll do a much better job then the Windows uninstaller.
     
  7. Wimalaya

    Wimalaya Thread Starter

    Joined:
    Dec 22, 2011
    Messages:
    199
    i uninstalled it, rebooted. Ableton is running and no blue screen, but i do not have sound and i cannot record.
    and i really liked the video capture program, it didnt make the videos choppy. is there a way to use it without it being in conflict with asio4all ?

    thanks
     
  8. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,613
    Go in to the Device Manager and see if there are any flag in the sound.

    What does it do when you try and record? Are you getting errors?
     
  9. Wimalaya

    Wimalaya Thread Starter

    Joined:
    Dec 22, 2011
    Messages:
    199
    what u mean by flags? i dont see anything unusual.

    when i play a recorded song, it plays and i see the volumemeters go up and down but no sound.
    when record is on, it doesnt do anything.
     
  10. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,613
    This may sound dumb, but is the sound muted?
     
  11. Wimalaya

    Wimalaya Thread Starter

    Joined:
    Dec 22, 2011
    Messages:
    199
    hehe, no, i have sound everywhere else... it just in ableton
     
  12. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,613
    Sorry, I don't know that program. There must be a setting there they'll mute and unmute.
     
  13. Wimalaya

    Wimalaya Thread Starter

    Joined:
    Dec 22, 2011
    Messages:
    199
    i didnt change any settings so the sound should be working. i even installed a newer version of asio4all.
    i rebooted again.
    microphone is working...


    still no sound from ableton :(

    i dont know what else to look for


    but thank you Lance, i appreciate the help


    EDIT: When i select the DirectX Realtec driver i have sound and mic is working but with huge latency, thats why i need asio4all driver... i can select it but as soon as do , no sounds..
     
  14. Wimalaya

    Wimalaya Thread Starter

    Joined:
    Dec 22, 2011
    Messages:
    199
    thanks for Revo Uninstaller. nice program.

    i noticed that all this stuff came along on the same day (24/12/12) i think together with the ZoomPlayer as i mentioned before..
    can one of these have messed up some things?

    Zoom Player
    ffdshow v1.2.4453
    Bass Audio Decoder
    LAV Filter 0.54.1
    MadVR
    DirectVobSub
    OpenSource Flash Video Splitter
    AC3Filter 2.5b
    DScaler 5Mpeg Decoders
    OpenSource DTS/AC3/DD+ Source Filter
    Gabest MPEG Splitter
    OpenSource AVI Splitter
    CD Audio Reader Filter
    FFMPEG Core Files
    DCoder Image Source
     
  15. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,613
    Here's a process you can try, Perform a Clean Startup in Windows 7 Follow the instructions and see if you can track down the problem app. That is if one of those app is the culprit. Let us know how it goes.
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Solved ASIO4ALL Debut
  1. ozegirl
    Replies:
    10
    Views:
    758
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1088992

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice