1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: ATI Rage Fury Driver for Gemstar 19" LCD Monitor (No display)

Discussion in 'Hardware' started by Myrrh, Mar 31, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. Myrrh

    Myrrh Thread Starter

    Joined:
    Nov 23, 2002
    Messages:
    27
    Just bought a 19" Gemstar LCD flat screen monitor. It works perfectly when plugged into my laptop. On my PC however, it only works in safemode and normal bootup with the lowest resolution (600x480 8bit). I have to press f8 during normal boot up though and select "enable vga mode" everytime so it will show the desktop with the lowest resolution. It would've been fine, except that the screen seems way too large than what I'm used to, can't even see the bottom areas to click the ok or cancel buttons on some settings. Can't change resolutions either, whole thing just restarts the PC. If booting up normally without pressing f8, a blank screen just comes up after the initial boot up and XP logo screens. Also tried to disable my start up items to see if it might be other software problems/conflicts possibly causing the invalid mode but all that did was cause my PC to give a nasty error that I've had to resolve.

    I have Windows XP Pro SP1 and an S/I ATI Rage Fury 32mb/TV cmpl video card. Does anyone know if updating the video card fixes the problem and if so, which driver needs to be installed? Tried searching the net for this problem, the nearest one I found is the thread but it still doesn't answer or help with my dilemma:

    http://www.pcreview.co.uk/forums/thread-2319371.php

    Any help/response would be appreciated. Thanks.
     
  2. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
  3. Myrrh

    Myrrh Thread Starter

    Joined:
    Nov 23, 2002
    Messages:
    27
    Thanks, Rollin' Rog! Tried the links and what you said and finally got the LCD up and running as it should. I loved my old CRT but this is way better. Thanks so much for your help. :D
     
  4. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
  5. Myrrh

    Myrrh Thread Starter

    Joined:
    Nov 23, 2002
    Messages:
    27
    Clear Type sure looks better. (y) Thanks for the tip(s). :D
     
  6. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/454514

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice