1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Autorun.inf not working with usb stick

Discussion in 'Windows 7' started by EagleEye75, Apr 28, 2015.

Thread Status:
Not open for further replies.
Advertisement
  1. EagleEye75

    EagleEye75 Thread Starter

    Joined:
    Apr 8, 2015
    Messages:
    122
    Tech Support Guy System Info Utility version 1.0.0.2
    OS Version: Microsoft Windows 7 Home Premium, Service Pack 1, 64 bit
    Processor: AMD Athlon(tm) II X2 220 Processor, AMD64 Family 16 Model 6 Stepping 3
    Processor Count: 2
    RAM: 1791 Mb
    Graphics Card: NVIDIA GeForce 6150SE nForce 430, 256 Mb
    Hard Drives: C: Total - 456838 MB, Free - 281364 MB; H: Total - 1907726 MB, Free - 1044120 MB;
    Motherboard: eMachines, EL1358
    Antivirus: 360 Total Security, Updated and Enabled

    Hi

    I have this unusual problem with my usb autorun.inf files running the drive icons ..they work if the pc is either switched on with them plugged in or restart with them in

    But if I take the usb stick out and then put it back in the autorun.inf files seems to not run (see the pics)

    what i want is for the icons to appear as I insert them with no need to reboot if possible

    also open to other solutions to the usb stick icon problem

    thanks in advance :)

    EDIT: i tried a thing were i downloaded a reg file to unlock autorun.inf but it did not help
     

    Attached Files:

  2. flavallee

    flavallee Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    80,686
    First Name:
    Frank
    I'm not sure how to address your USB thumb drive issue, but I do have some advice for you.

    You're running Windows 7 64-bit in that eMachines EL1358 desktop with only 2 GB(2048 MB) of RAM.

    You should increase it to 4 GB(4096 MB) or max it out with 8 GB(8192 MB).

    Speed and "snappiness" will noticably improve.

    ---------------------------------------------------------
     
  3. EagleEye75

    EagleEye75 Thread Starter

    Joined:
    Apr 8, 2015
    Messages:
    122
    Thanks for the advice.. I know I am running low in ram but do not have cash to do anything about that the now but when I can I will :)
     
  4. DaveBurnett

    DaveBurnett Account Closed

    Joined:
    Nov 11, 2002
    Messages:
    12,970
    I seem to remember that there was a security issue and autorun is disabled by default for USB.
    That was years ago and without looking it up I cannot remember whether it still applies.

    I certainly have it turned OFF on all the machines I have ever been responsible for.
     
  5. EagleEye75

    EagleEye75 Thread Starter

    Joined:
    Apr 8, 2015
    Messages:
    122
    Hi

    Thanks for reply

    yeah i read about that but a couple of weeks ago it was working so dunno what I did to break it and think the line commands for label and icons are allowed in windows 7 just not programs and such but not sure on that (maybe someone will know different) but sure I read that somewhere.

    So you turned it off and does you thumb drives still have icons somehow or is it one thing that never concerns you.
     
  6. EagleEye75

    EagleEye75 Thread Starter

    Joined:
    Apr 8, 2015
    Messages:
    122
    update on this problem

    Ok seems the Autorun.inf is being delayed in someway by something because I walked away and left my thumb drive after putting it in and the icon is there it used to be immediate.

    this is very strange
     
  7. DaveBurnett

    DaveBurnett Account Closed

    Joined:
    Nov 11, 2002
    Messages:
    12,970
    Is it a virus checker scanning the drive before showing it.
    Since showing any icons from executables requires opening them I would hope your virus checker scans them first.
    Also if there is an error of any sort in the file system on that drive, it may take time to open it.
    I would scan both the file system and for viruses.
     
  8. EagleEye75

    EagleEye75 Thread Starter

    Joined:
    Apr 8, 2015
    Messages:
    122
    I was thinking that I ran a scan with 360 total security it came back good with both the system and the flash drive also I had actually uninstalled it to see if it was my antivirus but same problem happened with it uninstalled so cannot be that ( 360 total Security has since been re-installed)

    I may have to just live with this or re-install windows again I do feel something somewhere has gotten corrupt it must be no other explanation for it.
     
  9. EagleEye75

    EagleEye75 Thread Starter

    Joined:
    Apr 8, 2015
    Messages:
    122
    Thanks to ALL who looked but I have other issues with PC so I am just going to look into restoring it back to factory.

    So will mark this as solved and unsubscribe to this thread and if needed make another thread as problem is different.

    Again thanks for looking
     
  10. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Solved Autorun working
  1. ozegirl
    Replies:
    10
    Views:
    2,336
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1147418

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice