1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: BOOTMGR is missing - after failed recovery from partition on a gateway laptop

Discussion in 'Windows Vista' started by Riceloft, Sep 11, 2008.

Thread Status:
Not open for further replies.
  1. Riceloft

    Riceloft Thread Starter

    Jan 14, 2004
    Hello, I'm attempting to repair a gateway laptop that came pre-loaded with Windows Vista Home Premium.

    I attempted a recovery to factory state with saving user data. During this process the laptop locked up and I was forced to power it down. When I start it back up, I get this message:

    BOOTMGR is missing
    Pres Ctrl+Alt+Del to restart

    I can't access the recovery partition anymore. In order to access it to begin with I had to press f8 to reach the advanced startup options and choose "Repair your Computer". I can no longer reach the advanced startup menu.

  2. Orumph


    Jun 10, 2007
    Most of the time (I guess not always) to get to the restore partition it is one of the following...


    These will be done at the same point you start hitting F8

    One of those combos usually works.

    Gateway may have done things differently.

    But if you can not get to the restore partition, and you did not create the restore disks,
    Then you will need to contact gateway to order the restore disks.

    However, it is possible that you may have a bad hard drive.
    You can usually check the BIOS for the model number and look up the manufacturer to get the HDD Diags from them. Toshiba Drives have no diags. Or, the HDD Diags could be in the BIOS somewhere, you will have to look for them, if they are there.

    If you can't fidn it that way, you will need to pull the Hard Drive and see who the manufacturer is and then, get the HDD Diags from them. To check and make sure the HDD is ok before trying to reload the OS.

    There are many things that can cause an issue like this. Memory is another, if the memory is bad, it is possible to cause Data Corruption. Use Windows Memory Diag for that.

    My first step to take would be, test the Hard Drive. If this passes,,,,
    Then test the memory, just to make sure. If this passes,,, and you still can't get to the restore partition....

    Then something horked the data on the drive (it would be unknown how or what might have casued it) and you will need to order those restore disks. Or if you can find an OEM version of the OS that came with your system, you can use that to reload it. Or buy a retail copy and load that.
  3. Riceloft

    Riceloft Thread Starter

    Jan 14, 2004
    Well, none of those worked, but I worked my way around the problem. I had a dell Vista Home Basic restore DVD. I installed that while leaving the Gateway restore partition intact. After it was installed, I went to the advnaced startup menu, and thankfully Gateway's recovery option had re-appeared after the "repair your computer" option was selected.

    Thanks though!
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/749025