1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Built-in Webcam not working

Discussion in 'Windows 7' started by danny21, Oct 1, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. danny21

    danny21 Thread Starter

    Joined:
    Oct 1, 2011
    Messages:
    7
    hey, i have an hp g42 laptop with windows 7 and the webcam wont work. when i start up cyberlink youcam, it says: "Warning, No webcam detected. Try plugging in a webcam into your computer now. If you are using an integrated camera, make sure that it is turned on". It worked when i first got my computer for a few months, then it stopped. I havent used it for a few months because of this problem. Please help me! Any help is appreciated, thanks!
     
  2. TheShooter93

    TheShooter93 Cody Malware Specialist

    Joined:
    Jul 9, 2008
    Messages:
    11,016
    There should be more to that model number.

    If you can't find it, can you find the product number on the PC?

    It should look like this:
    [​IMG]
     
  3. danny21

    danny21 Thread Starter

    Joined:
    Oct 1, 2011
    Messages:
    7
    on the bottom theres a sticker, on it it says the product key, and numbers next to and under the barcodes. is that what you're talking about?
     
  4. TheShooter93

    TheShooter93 Cody Malware Specialist

    Joined:
    Jul 9, 2008
    Messages:
    11,016
    Yes, I need the product key or the full model number.
     
  5. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,485
    What are you doing posting the install key for the world to see? Delete it right away.

    TheShooter93, you should know better then to ask danny21 to post the product key!
     
  6. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,485
    danny21, Go into the device manager, Windows key + Pause Break \ Device Manager Are there any exclamation marks by the web cam?
     
  7. danny21

    danny21 Thread Starter

    Joined:
    Oct 1, 2011
    Messages:
    7
    when i went to device manager i didnt see the camera but i saw "Universal Serial Bus controllers" and under that theres 3 things that say "Standard Enhanced PCI to USB Host Controller" and 4 that say "Standard OpenHCD USB Host Controller". all of them have the exclamation marks in front of them.
     
  8. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,485
    Thanks Danny21. We are talking about a built in we can aren't we? As for the USB's double click on one of the problem controllers. In Device Status, What does it say?
     
  9. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,485
    What is the exact model of the system? Go HERE and pick it out.
     
  10. danny21

    danny21 Thread Starter

    Joined:
    Oct 1, 2011
    Messages:
    7
    yeah its built in. what do you mean the problem controllers and device status? and i didnt see it on the list but under the keyboard it says "G42-415DX Notebook PC"
     
  11. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,485
    That's the one Danny21. Just for an example, say that this controller in the image is the problem. Double click it and the properties box will open. Highlight whats in the Device Status and past it here.




    [​IMG]
     

    Attached Files:

    • 1.gif
      1.gif
      File size:
      190.6 KB
      Views:
      77,479
  12. danny21

    danny21 Thread Starter

    Joined:
    Oct 1, 2011
    Messages:
    7
    ok all of them say:

    Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)
     
  13. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,485
    Go HERE and follow the troubleshooting steps there for Code 19. Keep us posted OK!
     
  14. TheShooter93

    TheShooter93 Cody Malware Specialist

    Joined:
    Jul 9, 2008
    Messages:
    11,016
    I misunderstood the OP and used the wrong term, my apologies. I needed the information like that represented in the screenshot I posted.

    Of course I wouldn't want them to post the validation key for their OS.

    Again, sorry for the trouble danny21 and Lance1.
     
  15. danny21

    danny21 Thread Starter

    Joined:
    Oct 1, 2011
    Messages:
    7
    no its cool, and I GOT IT! thank you soo much!! hahahaha im so happy, it didnt work for like 6 months! THIS IS AWESOME lol
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1020184