Solved: C: Drive seen as F: ??

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

johnnieq

Thread Starter
Joined
Nov 27, 1999
Messages
292
I have a computer here with one hard drive. Windows sees it as F: drive. How can I change it back to C:?
 
Joined
Mar 8, 2004
Messages
7,794
What do you have for C and D drives? Any zip drives or something similar? XP has this "feature" and unlike other versions of Windows your drive with the operating system on it does automatically become C.
 
Joined
Apr 5, 2005
Messages
281
that's very strange. in my experience, F:\ is normally assigned to USB hard drive devices. anything else attached to that machine?
 

crjdriver

Moderator
Joined
Jan 2, 2001
Messages
42,768
johnnieq said:
I have a computer here with one hard drive. Windows sees it as F: drive. How can I change it back to C:?
If that is the system drive, it CAN be changed to C however I do not recommend you do so for two reasons.

1 When you install and app it installs files to its own folder and it installs some files to windows or windows\system32 folders. If you change the path from F:\windows to C:\windows, those apps will not find the .dll type files they look for. The result is you must reinstall the app.

2 It is a somewhat involved process, however if you really really want to do this here are the instructions.


Make a full system backup of the computer and system state.
Log on as an Administrator.
Start Regedt32.exe.
Go to the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

Click MountedDevices.
On the Security menu, click Permissions.
Verify that Administrators have full control. Change this back when you are finished with these steps.
Quit Regedt32.exe, and then start Regedit.exe.
Locate the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

Find the drive letter you want to change to (new). Look for "\DosDevices\C:".
Right-click \DosDevices\C:, and then click Rename.

Note You must use Regedit instead of Regedt32 to rename this registry key.
Rename it to an unused drive letter "\DosDevices\Z:".

This frees up drive letter C.
Find the drive letter you want changed. Look for "\DosDevices\D:".
Right-click \DosDevices\D:, and then click Rename.
Rename it to the appropriate (new) drive letter "\DosDevices\C:".
Click the value for \DosDevices\Z:, click Rename, and then name it back to "\DosDevices\D:".
Quit Regedit, and then start Regedt32.
Change the permissions back to the previous setting for Administrators (this should probably be Read Only).
Restart the computer.


BTW I would just reinstall the os making sure you remove any zip drive, card reader, or removable drive before you start the install. You can install that later.
 
Joined
Sep 1, 2004
Messages
1,756
This happens when you install Windows 2000/XP and a device is already using the earlier drive letters. If you have a card reader installed this will happen, you need to plug it in after Windows has been installed. The only safe way to change it back to C: is to back up your data, then format and reinstall Windows from scratch (remove the card reader first!). A repair install of Windows will not fix this.
 

T.M.

Banned
Joined
Jul 2, 2005
Messages
12
It can be changed back to C: but i wouldnt recommend that you do change it because if you do your computer wont recognize certain files (dll. files mostly)...having a drive F: is not much different than having a drive C: except for the fact that they are 3 places apart from each other in the alphabet..LOL.... :D
 
Joined
Apr 5, 2005
Messages
204
Trebuchet said:
that's very strange. in my experience, F:\ is normally assigned to USB hard drive devices. anything else attached to that machine?
I have 3 HDs, I have an F:\....can't you choose the drivename anyways?
 

johnnieq

Thread Starter
Joined
Nov 27, 1999
Messages
292
OK. This computer only has one hard drive and one CD-RW. T he hard drive is "F:" and the CD-RW is "D:"

No other zip drives, card readers, nothing. I tried a reinstall and as someone had said, that didn't solve it. I contacted a localcomputer store that said Partition Magic could set it back to C:. I tried it and the computer would not reboot, so I did a complete reinstall. Luckily I had backed up the system when it was brought to me.

Thanks for your suggestions....
 

crjdriver

Moderator
Joined
Jan 2, 2001
Messages
42,768
When you do the clean install, are you deleting all partitions on the disk and creating just one?

Are any usb devices plugged in during the install?
 

johnnieq

Thread Starter
Joined
Nov 27, 1999
Messages
292
I guess I wasn't very clear in my last post, but the clean install gave me a normal C: boot drive.

Thanks again to everyone for their help. :)
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top