1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Cannot Communicate With Primary DNS Server

Discussion in 'Networking' started by adamblacky, Mar 28, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. adamblacky

    adamblacky Thread Starter

    Joined:
    Mar 28, 2008
    Messages:
    12
    I have just got a vista laptop from work and when i use it with the wireless at work the internet works fine, but when i try and access my wireless internet at home it connects to the router but cannot connect to the internet. The router is working correctly as other people are using it and it's working fine. When i try and diagnose problems it says:

    Cannot communicate with primary DNS server (10.0.1.200)
    (Network diagnostics pinged the remote host but did not receive a response)

    Then there is an option to reset the network adaptor and when clicked it trys repairing it and then it says:

    Windows tried a repair but a problem still exists. Cannot communicate with primary DNS server(10.0.1.200)

    Again there is an option to reset the network adaptor. It just goes round in circles.
    I have googled the problem but no-one seems to have the same problem.
    Any help will be very much appreciated.
    Thanks ver much, Adam.
     
  2. Compaq__

    Compaq__

    Joined:
    Mar 18, 2008
    Messages:
    458
    go to a command prompt...type IPCONFIG /ALL and post the results here.

    What is the IP address of your router.
     
  3. cwwozniak

    cwwozniak Chuck Trusted Advisor

    Joined:
    Nov 28, 2005
    Messages:
    49,399
    The 10.0.1.200 IP address is a private IP address of the Domain Name Server (DNS) on your work network. A private IP address can not be accessed directly from outside that network. A Domain Name Server is used to translate a URL like www.techguy.org into the public IP address [209.183.226.152] that your browser needs for the actual connection.

    You may want to talk to your IT people at work about setting up your computer to operate on other networks besides the one at work.
     
  4. Compaq__

    Compaq__

    Joined:
    Mar 18, 2008
    Messages:
    458
    If your work could just set you up to use DHCP instead of having the info. hardcoded (which is probably how it is) you would have more luck.
     
  5. adamblacky

    adamblacky Thread Starter

    Joined:
    Mar 28, 2008
    Messages:
    12
    Here it is :

    Microsoft Windows [Version 6.0.6000]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.

    C:\Users\user>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : user-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : Belkin

    Ethernet adapter Bluetooth Network Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
    Physical Address. . . . . . . . . : 00-1E-37-99-90-25
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wireless Network Connection:

    Connection-specific DNS Suffix . : Belkin
    Description . . . . . . . . . . . : Dell Wireless 1390 WLAN Mini-Card
    Physical Address. . . . . . . . . : 00-1F-3A-49-B4-C7
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::2c4f:71cf:dbdd:cc1a%10(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.2.5(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : 28 March 2008 14:06:25
    Lease Expires . . . . . . . . . . : 28 March 2009 14:06:24
    Default Gateway . . . . . . . . . : 192.168.2.1
    DHCP Server . . . . . . . . . . . : 192.168.2.1
    DHCPv6 IAID . . . . . . . . . . . : 167780154
    DNS Servers . . . . . . . . . . . : 10.0.1.200
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controll
    r
    Physical Address. . . . . . . . . : 00-1D-09-B9-59-D7
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 6:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 02-00-54-55-4E-01
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 7:

    Connection-specific DNS Suffix . : Belkin
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::5efe:192.168.2.5%13(Preferred)
    Default Gateway . . . . . . . . . :
    DNS Servers . . . . . . . . . . . : 10.0.1.200
    NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter Local Area Connection* 9:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 11:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    C:\Users\user>ipconfig /all


    I don't really know how to find my router's IP sorry.
     
  6. Compaq__

    Compaq__

    Joined:
    Mar 18, 2008
    Messages:
    458
    Add a DNS server to the list. 192.168.2.1

    See if that works.
     
  7. Wanderer2

    Wanderer2

    Joined:
    Jan 28, 2008
    Messages:
    1,428
    In other words your dns listing in your wireless router is wrong. Correct it and you should be fine.
     
  8. adamblacky

    adamblacky Thread Starter

    Joined:
    Mar 28, 2008
    Messages:
    12
    how do i do that please?
     
  9. Compaq__

    Compaq__

    Joined:
    Mar 18, 2008
    Messages:
    458
    Sorry....I should have explained to you.

    I'm looking at Windows XP here so there might be a variation between that and Vista but the principle is the same.

    Go into CONTROL PANEL. Click on NETWORK CONNECTIONS.

    You should see a WIRELESS NETWORK CONNECTION in there. Right-Click on it and click PROPERTIES.
    Find INTERNET PROTOCOL (TCP/IP) in the list
    Click Properties
    Click ADVANCED
    Click the DNS tab
    Click ADD
    Type the IP Address 192.168.2.1
    Click ok on everything and run that repair again just to make sure it takes the new info.
     
  10. adamblacky

    adamblacky Thread Starter

    Joined:
    Mar 28, 2008
    Messages:
    12
    Works a treat. Thanks very much for your help!

    Adam.
     
  11. Compaq__

    Compaq__

    Joined:
    Mar 18, 2008
    Messages:
    458
    You are quite welcome. If ya get a chance, just go into your thread tools at the top here and mark the thread SOLVED.

    Take care.
     
  12. Wanderer2

    Wanderer2

    Joined:
    Jan 28, 2008
    Messages:
    1,428
    Guess that is one way of addressing the issue but it doesn't correct it.

    You are doing dhcp at home according to your ipconfig post. The router is giving you the wrong dns entry 10.0.1.200

    You put 192.168.2.1 into IE and it will present you with your routers login page. Login and go to the lan settings. Change the dns setting here. Save the config and exit.

    Now you have corrected the entry permanently.
     
  13. Compaq__

    Compaq__

    Joined:
    Mar 18, 2008
    Messages:
    458
    That DNS entry is hardcoded most likely because that is the DNS server used for WORK.

    The router isn't giving him that DNS entry...if it was then it wouldn't be working for others as he said it is.

    Adam, what I said corrects the issue.
     
  14. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/697922