1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Cannot connect Laptops (running Vista) to Wireless Belkin 54g Router

Discussion in 'Networking' started by laurandeclan, Aug 20, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. laurandeclan

    laurandeclan Thread Starter

    Joined:
    Aug 20, 2008
    Messages:
    4
    Hi there,

    I've recently bought two new laptops, running Vista, and am having trouble wirelessly connecting them to my wireless network on my Belkin 54g Router. I can see the network I need to connect to, and the signal is 100% but when I try to connect it keeps saying disconnecting and something about WLAN :confused::mad:. Unfortunately, i'm not very technical. I just about managed to follow the Router's inital set up.

    Not sure whether you need to know but when the Router was first set up I set up two passwords, a main password and a guest password.

    Also not sure whether you need to know but the network will allow me to plug my LAN cable in and will let me connect no problem.

    I have successfully connected my old PC to the desired network, wirelessly, with the use of the Belkin Wireless Adaptor.

    I hope there is someone who can help me with my problem.

    Thanks in advance :)
     
  2. Wilsonjc

    Wilsonjc

    Joined:
    Aug 20, 2008
    Messages:
    8
    Do you have any security on the wireless (wpa/wep etc) or mac address filtering? Vista has issues with some versions of the protocols that security keys use. ( wpa version 1 off the top of my head)

    Thanks

    John
     
  3. laurandeclan

    laurandeclan Thread Starter

    Joined:
    Aug 20, 2008
    Messages:
    4
    When I set up the router i opted for the secure wireless option therefore setting up two passwords.
     
  4. Wilsonjc

    Wilsonjc

    Joined:
    Aug 20, 2008
    Messages:
    8
    Sorry I should have been clearer,

    What type of the encryption have you used? WPA WEP?? Vista hates WPA (not sure why)

    Try changing to WEP or removing ( briefly) to see if you can connect.

    Thanks

    john
     
  5. laurandeclan

    laurandeclan Thread Starter

    Joined:
    Aug 20, 2008
    Messages:
    4
    You were very clear! I am just blonde...very blonde when it comes to computers. I will try that and get back to you.

    Many thanks for your help!
     
  6. Wilsonjc

    Wilsonjc

    Joined:
    Aug 20, 2008
    Messages:
    8
    No worries,

    let me know how it goes,

    John
     
  7. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,167
    First Name:
    Terry
    That's incorrect. There have been some reports of Vista having issues with WEP, but Vista handles WPA and WPA2 just fine.

    Regardless, it's wise to disable encryption to eliminate one variable until you get a succesful connection. Make sure you have the latest driver from the laptop manufacturer's web site for the wireless adapter (I'm assuming it's integrated since you didn't say), try to connect via wireless and show ...

    Start, Run, CMD, OK to open a command prompt:
    (For Vista type CMD in the Search box after Start)

    Type the following command:

    IPCONFIG /ALL

    [Note that there is no space between the slash and ALL.]

    Right click in the command window and choose Select All, then hit Enter.
    Paste the results in a message here.

    If necessary use a text file and removable media to copy the results to a computer with internet access.
     
  8. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Changes that may help to increase the compatibility of Vista with older networking devices:



    Disable the IP Helper service:

    1. Hold the Windows key and type R, enter "services.msc" (without the quotes) and press Enter
    2. Scroll down to the IP Helper service, right click on it and select Properties
    3. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"
    4. Then click on "Stop" to stop the service from running in the current session
    5. Click OK to exit the dialog



    Disable IPv6:

    1. Hold the Windows key and type R, enter "ncpa.cpl" (without the quotes) and press Enter
    2. Right click on each network connection and select "Properties"
    3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)
    4. Click OK to exit the dialog

    NOTE: You should do this for each network connection.



    Disable the DHCP Broadcast Flag:

    Link: http://support.microsoft.com/default.aspx/kb/928233
    1. Hold the Windows key and type R, enter regedit and press Enter.
    2. Locate and then click the following registry subkey:
    3. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
    4. In this registry path, click the (GUID) subkey to be updated.
    5. If the key DhcpConnForceBroadcastFlag does not exist, use the Edit menu, point to New, and then click DWORD (32-bit) Value. In the New Value #1 box, type DhcpConnForceBroadcastFlag, and then press ENTER. If the key exists, skip this step.
    6. Right-click DhcpConnForceBroadcastFlag, and then click Modify.
    7. In the Value data box, type 0, and then click OK.
    8. Close Registry Editor.
    NOTE: You should do this for each and every GUID subkey.
    NOTE2: (GUID) is a mnemonic for the individual subkeys, the actual text "GUID" does not appaer.




    The only program I'm aware of that currently relies on IPv6 is the new Windows Meeting Space. The first 2 changes will cause that program not to work - but will leave all of your normal (IPv4) connections unaffected. If it causes problems that you can't overcome, simply revert back to the original settings.
     
  9. Wilsonjc

    Wilsonjc

    Joined:
    Aug 20, 2008
    Messages:
    8
    Terrynet: I gotta be honest in my experiance and browsing the web, vista does indeed hate wpa, ( experiance, IT engineer for an ISP) if you read technet there are many people who have the same issues.

    Not sure if it happens with WEP I couldn't say, we don't use it,.

    Thanks

    John
     
  10. laurandeclan

    laurandeclan Thread Starter

    Joined:
    Aug 20, 2008
    Messages:
    4
    John (wilsonjc),

    Just to say it worked a treat. I reset the router and reinstalled it, selected WEP and set up a HEX Key and he presto Bob's your Uncle and all that...it works and I am now a very happy bunny!!!

    Thank John for all your help!

    Laura
    xxxx
     
  11. Wilsonjc

    Wilsonjc

    Joined:
    Aug 20, 2008
    Messages:
    8
    Always a pleasure.

    Thanks

    John
     
  12. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    I suggest you keep in mind that WEP offers anemic security and is easily cracked with common tools available on the Internet. The major flaw in WEP is the reason that WPA/WPA2 exist.

    I'll also state that there is no documented reason that WPA won't work on Vista, and I've had lots of Vista experience and never had that issue. I have had WEP have problems on several laptops.

    I'm pretty convinced that you could indeed get WPA working, and you'd have much better security.
     
  13. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/741894

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice