Solved: Can't share internet connection over Wireless Network

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

sobroken

Catherine
Thread Starter
Joined
May 11, 2002
Messages
195
Hi,

Setting up a wireless network at my boyfriend's. He has 2 PCs both running XP Home SP2 and has a D-Link DSL-G624T router with a USB dongle in the 2nd PC.

Network itself is set up fine, the two computers can see each other and share files. The only problem is that I can't share the internet connection.

I went into Network Connections on the PC that's plugged into the router and opened up the Local Area Connection properties, looked on the Advanced tab, and the Intenet Connection Sharing bit is missing! How on earth do I share the connection without it?

Sorry for being clueless, but I really need some advice.

Hope I've provided enough info.

Thanks for any help you can give.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,429
You don't need ICS if you're using a router, and it will actually screw things up! Plug both of the machines into the router, problem solved!
 

sobroken

Catherine
Thread Starter
Joined
May 11, 2002
Messages
195
Thanks for the response.

The thing is, I'd like to connect wirelessly if possible. The plan is to have the PCs on opposite sides of the room without cables. Plus I want to be able to share the connection later on with my wireless laptop.

Any ideas on what I could be missing? Thanks again for your help.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,429
Like I said, you do NOT want ICS in the mix. Since you have a wireless router, all you need is a wireless adapter for each of the machines in question. The laptop probably already has a wireless NIC, so you just need one for the machine that doesn't have one.
 

sobroken

Catherine
Thread Starter
Joined
May 11, 2002
Messages
195
I already have a wireless adapter on the second PC. It's working fine as far as networking is concerned, ie I can see both computers on the network, I can share files between them, and they both show up in My Network Places.

The first computer (which is plugged into the router) can use the internet fine. The second PC, however, cannot. That's the problem.

From your post, it seems as though the internet should be shared autmatically as part of the network, but it isn't! I assumed I needed to set permissions for this somewhere, but I guess not.

Thanks for your help, I hope this explains it a bit more clearly.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,429
How about some details about the second computer. You are correct, it should be automatic. What's the make/model of network card or wireless adapter.



For the second computer that's not seeing the Internet, let's also see this.

Start, Run, CMD to open a command prompt:

Type the following command:

IPCONFIG /ALL

Right click in the command window and choose Select All, then hit Enter.
Paste the results in a message here.

If you are on a machine with no network connection, use a floppy, USB disk, or a CD-RW disk to transfer a text file with the information to allow pasting it here.



Finally, do this test.

Try these simple tests.

Start, Run, CMD to open a command prompt:

PING 216.109.112.135

Tell us the results.

PING yahoo.com

Tell us the results.
 

sobroken

Catherine
Thread Starter
Joined
May 11, 2002
Messages
195
Hello,

Here are the results of the pinging etc:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Spaz>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : home-25f4a92d30
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
Physical Address. . . . . . . . . : 00-30-18-A1-7C-45

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : D-Link AirPlus G DWL-G122 Wireless U
SB Adapter(rev.C)
Physical Address. . . . . . . . . : 00-17-9A-B8-E5-E8
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.3
Subnet Mask . . . . . . . . . . . : 255.255.255.0
IP Address. . . . . . . . . . . . : fe80::217:9aff:feb8:e5e8%6
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
Lease Obtained. . . . . . . . . . : 06 July 2007 17:56:34
Lease Expires . . . . . . . . . . : 06 July 2007 18:56:34

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : FF-FF-FF-FF-FF-FF-FF-FF
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::5445:5245:444f%5
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface

Physical Address. . . . . . . . . : C0-A8-01-03
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::5efe:192.168.1.3%2
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Documents and Settings\Spaz>ping 216.109.112.135

Pinging 216.109.112.135 with 32 bytes of data:

Reply from 216.109.112.135: bytes=32 time=102ms TTL=51
Reply from 216.109.112.135: bytes=32 time=101ms TTL=51
Reply from 216.109.112.135: bytes=32 time=102ms TTL=51
Reply from 216.109.112.135: bytes=32 time=103ms TTL=51

Ping statistics for 216.109.112.135:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 101ms, Maximum = 103ms, Average = 102ms

C:\Documents and Settings\Spaz>ping yahoo.com

Pinging yahoo.com [1.0.0.0] with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 1.0.0.0:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Documents and Settings\Spaz>

I hope that sheds some light on my problem

Thanks again for your help.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,429
Follow the directions on OpenDNS to change your DNS address to their servers and see if that makes this machine function.
 

sobroken

Catherine
Thread Starter
Joined
May 11, 2002
Messages
195
We have just figured it out!

We noticed every time it tried to connect, it was looking for 1.0.0.0, so I Googled this and came up with the solution, which was to disable IPv6 on the second computer.

It worked fine!

So thanks for all your help, it's all better now.
 
Joined
Aug 28, 2007
Messages
2
Sir, i have linksys model wrt54g and my internet connection is not shared with client, how i can share the internet on the network?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top