1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Caps Lock not Releasing with Caps Lock key

Discussion in 'Windows Vista' started by DjIssues, May 6, 2009.

Thread Status:
Not open for further replies.
  1. DjIssues

    DjIssues Thread Starter

    May 6, 2009
    Unable to release "Caps Lock" in Windows, Only With "Shift" key, HELP please.?

    I recently had a power serge that frying 1 of my 6 internal 2TB sata hard-drives... After removing it and running some test to see if everything was ok other then that drive... I noticed my Caps Lock key was freezing on... I tried swapping it with another USB keyboard still the same problems then I tried swapping it with a PS/2 keyboard still the same issues... I can release the caps by pressing ether SHIFT key...

    I'm Currently running,
    Windows Vista Ultimate 64bit (Valid)
    8gb Ram,
    12TB of Disk space,
    (Post a comment if more info is needed, But I think this is more then enough info to help answer the question)

    I would really like to not have to press SHIFT every time to release the Caps Lock key.

    Thank you if anyone can help this issue.

    p.s. I've tried reinstalling the drivers & uninstalling from Device manager....
  2. Blackmirror


    Dec 5, 2006
  3. DjIssues

    DjIssues Thread Starter

    May 6, 2009
    Well I'd like to point out, that its not the case I never had a problem with this before, its only when I log into vista that it turns on, again this all started after a fluke power spike, crashing my computer...

    I can press Left Shift or Right Shift to release the Caps Lock key from being active but if I touch the Caps Lock key it dose nothing....

    all I want to do it be able to click Caps Lock and disable it not Shift.
    and I really don't want to format a full 2 TB hardrive
  4. flosty


    May 16, 2009
    I'm new to Windows 7 (never installed Vista), but they should be similar enough.

    In XP this 'problem' was enabled by creating a DWORD value named Attributes in HKEY_CURRENT_USER>Keyboard.

    It's actually something that people prefer as typewriters were like this, and I personally think it's a brilliant option. I'm trying to figure out how to turn it ON in 7!

    I have a feeling it could be a QWORD rather than DWORD as it is 64-bit, but then again I'm still working my way around.

    If you could have a look and let me know I'd appreciate your help haha!

    EDIT: I've just found a GUI option for 7 so give this (or a place thereabouts) a shot - Control Panel > Region and Language > Keyboards and Languages > Change keyboards > Advanced Key Settings > "To turn off Caps Lock > Press the CAPS LOCK key || Press the SHIFT key"
  5. DjIssues

    DjIssues Thread Starter

    May 6, 2009
    I managed to get it working :p
    "Start Menu"
    "Control Panel"
    "Change Keyboard or other input methods"
    Click the Tab "Keyboard and Language"
    then the option "Change Keyboard"
    then click the Tab "Advance Key Settings"
    then you see the option to turn Caps Lock key off with "Shift" or the "Caps Lock" key...

    hehe must have clicked that when tweaking my settings ...
    Its back to normal :)
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/824713

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice