Solved: cd-rom-device driver not found MSCD001

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

nstlgc1

Thread Starter
Joined
Oct 21, 2001
Messages
51
I've been trying to fix a kids computer. It is a Packard Bell Legend 401cd. I believe it's rather old. Anyway, it was running win95 and they tried using the upgrade win98 cd and crashed the system. I have partitioned the c: drive and formatted the c: drive. I tried to install win98 with startup floppy & cd but when the system boots up it says: device drive not found MSCD001 No valid cdrom device driver found. All I can work off of is the dos program. I have tried so many things that I can't remember them all, so I'm sorry I can't be of more help in that area. I have looked everywhere trying to find answers and have been unsuccessful. I learn with each computer fix-it I do, but this has me pulling my hair out.

The cd company is mashitsu and I have found that they and panasonic work together, but no drivers that I have tried to install will work. I'm not that computer fix-it literate so it gets confusing. So if you can help me, could you speak in easy computerese?

Thank you for your consideration.
 
Joined
Jul 29, 2001
Messages
21,334
Look at the line entries for the autoexec.bat and config.sys files. The autoexec should have smothing like this in it:
MSCDEX.EXE /D:MSCD001

and the config.sys should have something like this in it referencing the driver path:
DEVICE = MTMCDAI.SYS /D:MSCD001

the MSCD lines should be the same in both files.
 

nstlgc1

Thread Starter
Joined
Oct 21, 2001
Messages
51
:confused: Ok I found I could use my kids computer to open the start up disk (they have 98 I have me). Neither the autoexec.bat nor the config.sys has these in their files.

I was able to find the cd drivers on line thru Panasonic. I have loaded them in the c drive. Still nothing, except I now get the error message that I may have a problem with the cd-rom. Check to be sure they are plugged in properly and restart the computer. Ok, so I am looking at all this stuff under the hood here and have followed ribbons and wires - they all seem to plugged in (in the correct place who knows). When I start the computer the green light on the cd comes on.

With my kids computer can I add the lines that are needed? If so, what do I say and where do I put it?

Thanks for your help.
 

nstlgc1

Thread Starter
Joined
Oct 21, 2001
Messages
51
Im trying to fix a broken pc. It crashed. I have fdisked, formatted and now it won't read cd-rom. Was told by a friend I need to go into the autoexe.bat and config.sys to change drivers from start up disk. I have downloaded the cd-rom driver onto a floppy. And I know I was in the file once where I'm suppose to change these but can't remember where I found them. Any clue?

Also, once I'm in there, will I know what I'm suppose to change?
I'm just a Mom trying to help a neighbor kid. Don't know alot of computerese.... so if you could spell it out in simpleton I sure would appricate it.

Thanks for your consideration.
:p
 
Joined
Jun 28, 2001
Messages
46
Will the computer boot from the HDD or do you still need to use a floppy to boot? If you're using a floppy to boot use the command SYS to transfer the system files to the HDD that will allow it to boot. If you don't have the SYS command on your floppy, use FORMAT C: /q /s. That will do a quick format and transfer the system files over. Once you can boot from the HDD, we can move on to the CD-ROM drivers.

First, I assume that the computer is old enough that it cannot boot from the CD-ROM. Check boot sequence in BIOS to confirm that. If the computer can boot from the CD-ROM, set it to the first boot position and put a bootable CD in the drive, such as Win95b or Win98, and problem solved.

On to the drivers you have on the floppy disk. If the file you downloaded is a .exe file, you should be able to execute it from the floppy and it should automatically set up the autoexec.bat and config.sys files. If it is some other format or if it fails to set up the files, let us know and we can give you some other ideas.

Hope it helps!

BrianL
 

nstlgc1

Thread Starter
Joined
Oct 21, 2001
Messages
51
Thank you for responding so quickly. Here are some qualifiers.
No the computer will not boot from the hdd, it still wants the floppy. I looked in the directory and can only find command.com no command.sys so I'm not sure if I'm looking in the correct spot. I tried the FORMAT C: /q/s it says that I don't have the correct ms-dos version and it's terminating that command. The computer is somewhat outdated however, I do have the option of booting with cd first. I've tried that before and it won't do anything :confused: Regarding the drivers that I downloaded: They were zip files so I went back to Matsushita to download the exe file. Now this is also a confusing place. I went to www.mke.panasonic.co.jp/download/download.htm and looked for the cr-572. They have several to choose from and I'm not sure if I've downloaded the correct one. So I downloaded the os one and looked in director and typed what it had. It opened the file to other files, but now I don't know what to do.
I'm sorry for being so dumb about this, as I said before, I'm just a mom trying to help. Although I am certainly learning alot.

Any help you can continue to provide me would be greatly appreciated.
 

~Candy~

Retired Administrator
Joined
Jan 27, 2001
Messages
103,706
Boot with you windows bootable floppy disk to an A: prompt.

Put the floppy disk in where you have downloaded the cd rom drivers to......

at the A: prompt, type dir
and hit enter

do you see an install or setup? If so then type either
install
and press enter

or setup
and press enter

Allow changes to be made to the autoexec.bat and config.sys if you are prompted......
 

nstlgc1

Thread Starter
Joined
Oct 21, 2001
Messages
51
Thank you Candy for responding so quickly. I have done as you suggested. at the a: prompt I looked in dir. typed install. It's copying files (atapimgr.sys and sr_aspi.sys) and says looking for mscdex file - mscdex connet be located. is it seached for on the other drive y/n?
What do I say?
I don't want to muck this up as with everyone help I might get the blasted thing working.
 

~Candy~

Retired Administrator
Joined
Jan 27, 2001
Messages
103,706
Someone mentioned in another thread I was working on that it should be on the bootable floppy, I don't have one with me right now to verify.....but, you obviously have a working computer....just copy it from that one onto the floppy, then transfer it to the hard drive on the problem computer by typing:

copy mscdex.exe c:

and hitting enter....notice the space after the 'y' and after the last 'e' in .exe

EDIT

I just made one and I don't see it on mine either.....gonna have to figure out who told me that :confused:
 

nstlgc1

Thread Starter
Joined
Oct 21, 2001
Messages
51
Well, I went on-line and found the download for mscdex. Which I have now copied onto c:. I tried restarting the computer with my win98 floppy in along with the cd. When it boots up it says:
1. start computer with cd-rom support
2:start computer without cd-rom support
3. help

So I had it start with cd-rom support. The error report I am getting now is:

the diagnostic tools were successfully loaded to drive D
Device driver not found "MSCD001"
no valid CDROM device drivers selected

Now when I look in the c: dir it does not show the drivers for the matsushita cr-572 cd-rom. Do I load those now?

Thanks for sticking with me on this.
;)
 

~Candy~

Retired Administrator
Joined
Jan 27, 2001
Messages
103,706
Yes, it should now be able to find the file it was crying about earlier.
 

nstlgc1

Thread Starter
Joined
Oct 21, 2001
Messages
51
ok, I copied the floppy from a: to c:. I restarted the computer using cd-rom support. :( still getting the same error - device driver not found MSCD001.

Did I do something wrong? ugh!
 

~Candy~

Retired Administrator
Joined
Jan 27, 2001
Messages
103,706
You can't copy the cdrom files......just that one that you got from the internet......

You must do the install again like you were doing when it discovered it was missing that file.
 

nstlgc1

Thread Starter
Joined
Oct 21, 2001
Messages
51
Ok, I've started over. formatted c., installed the cd-rom driver and now have mscdex on my c drive. I'm not sure what Im suppose to do now as I still get the same error message stating no cdrom decive.....

When I type mscdex it wants me to put in all kinds of letters (which I have no idea what to put).

I'm sorry for being such a pain. It's just I'm really trying here and am getting so much farther with your help.

Any suggestions?
Thanks again!
 

~Candy~

Retired Administrator
Joined
Jan 27, 2001
Messages
103,706
Ok, the drivers that you downloaded for the cdrom that you said earlier that you had put on a floppy disk, and then I asked you to look for an install or setup by doing dir at the a: prompt?

Do the install again.........
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top