Solved: Computer asks for uninstalled operating system

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

RPT

Thread Starter
Joined
Nov 8, 2002
Messages
163
Hello all ... a long time ago I installed a second version of Windows XP on my computer. If memory serves, I installed it on the same directory as my original operating system. I uninstalled it shortly thereafter ... however, every time I boot up, the computer asks me which copy of XP I want to use. This despite the fact that I have since totally reinstalled windows and even replaced the physical hard drive! How can I get it to stop asking for an operating system that no longer exists?
Currently I am running XP Pro on an AMD Athlon 64 3000+ with 2 Gigs of RAM and 750 Gigs on 3 hard drives.
Many Thanks!!
 
Joined
Sep 9, 2001
Messages
1,930
RPT: I know of no way to stop the choosing but you can make it go away quicker.
Start>Run>type-msconfig>OK.
Click the Boot.ini tab and on the right is a Timeout box.
Enter 3 (that's the Minimum) and the two choices will be there for only 3 seconds.
The defaule is 30 secs. so you should sav 27 seconds and not have to push Enter.
 
Joined
Oct 25, 2007
Messages
2,393
Remove the extra operating system from boot.ini. example:

[boot loader]
timeout=12
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect
------------------------------------------------------------------------------------------
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect < Delete this one
------------------------------------------------------------------------------------------
 
Joined
Oct 25, 2007
Messages
2,393
The actual boot.ini file is on root of your system partition
To access it you could open a command prompt, type "cd\" then type "edit boot.ini"

or

Go to Control Panel > Folder Options > View tab, check the box "Show Hidden Files and Folders" and uncheck the box "Hide Protected Operating System Files" Open "My Computer" or the like and open your system drive. It will be right there.
 
Joined
Jan 17, 2003
Messages
10,254
For the easy and safe way . . Try this . . Click on Start . . Run . . type msconfig . . click on the Boot Ini tab and click on Check all boot paths . . if it comes back with one is invalid, click Fix invalid boot paths
 

RPT

Thread Starter
Joined
Nov 8, 2002
Messages
163
Changing the boot.ini file worked -- problem resolved!!
Many thanks!!
(y)
 
Joined
May 15, 2006
Messages
11,849
The fix that was used only removes the link to the operating system that was installed not the operating system itself. This operating system is linked to a lot of files and directories on the hard drive and you might want to think about getting rid of that to free up extra space.
 
Joined
Oct 25, 2007
Messages
2,393
So if I understand you correctly, you want RPT to remove the files associated with this extra boot.ini entry to save space. Now since this duplicate boot.ini entry was created by replacing the operating system in exactly the same partition, that would mean removing the rest of the startup files, operating system files, etc. leaving a completely unbootable harddrive. You're right that does save a lot of space!
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top