Solved: Customizing the path in Vista

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Alex Ethridge

Thread Starter
Joined
Apr 10, 2000
Messages
9,264
I have two folders on my C drive that I would like to have in my path statement. I have added them in Autoexec.bat, same as I have always done in 2000 and XP; but, Windows is ignoring the path statement in Autoexec.bat.

I even went into Computer> Properties> Advanced Settings and changed the path statement in Environment Variables; but, that did no good either.

How do I add folders to the path statement in Vista?
 

Squashman

Retired Trusted Advisor
Joined
Apr 4, 2003
Messages
19,786
By default XP never used the Autoexec.bat file so I don't know how you got it to work that way. You needed to make a registry edit to get it to parse the Autoexec.bat file which is pointless when you can just change the environmental variables in the system properties. It should work just by adding to the enviromental variables.

Open up a cmd prompt and type path to see if the settings took.
Copy and paste what you have in the path statement here so we can take a look at it.

Did you reboot after the change?
 

davehc

David
Retired Trusted Advisor
Joined
Oct 4, 2006
Messages
2,059
I,m not sure about the autoexec.bat not being read in XP. I thought it was. But we are dealing with Vista here and Vista most certainly does not read the Autoexec or config.sys files.
As Squashman states, what you did should have worked.
Fwiw. The statement should have looked something like:
TMP %USERPROFILE%\YourPath\etc
Later. Found this little tutorial. Nothing that hasn't already been said but very clear:
http://lifehacker.com/software/wind...iables-for-quick-folder-navigation-259018.php
 

Alex Ethridge

Thread Starter
Joined
Apr 10, 2000
Messages
9,264
By default XP never used the Autoexec.bat file so I don't know how you got it to work that way.
Well, I don't know why it worked; but, I never edited the registry and all I did was put Path C:\BAT;C:\EXE into Autoexec.bat and all my old batch files ran fine from any DOS window.
It should work just by adding to the enviromental variables.

Open up a cmd prompt and type path to see if the settings took.
Copy and paste what you have in the path statement here so we can take a look at it.
This is exactly what was in environment variables and this is also exactly as it displays in a DOS window:

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files\Common Files\Intuit\QBPOSSDKRuntime; C:\BAT;C:\EXE

I found the problem. Notice the space between "\QBPOSSDKRuntime;" and "C:\BAT;C:\EXE". Evidently, the space didn't keep it from displaying in a DOS window when the path statement was displayed; but, it obviously prevented the execution of the BAT and EXE folders. Anyway, I removed the space and all is well.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top