Solved: Dell Latitude D620 not connecting to wifi, but connecting at home

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

guavagirl

Thread Starter
Joined
May 21, 2007
Messages
7
Hi, I have a Dell Latitude D620 with a Dell Wireless WLAN. I connect to my wireless connection at home fine, but any time I take my computer to a wifi hotpsot, it cannot connect. I SEE that there is a network there, I click "connect" to that network, and my computer doesn't do anything. My Wireless is set to obtain IP addresses automatically, so that is not the problem. Does anyone have any suggestions on what I might try to fix this??

Thanks!
 
Joined
Apr 23, 2004
Messages
2,960
Also make sure that the "channel" for your wifi card is set to "Auto". Sometimes the Dell cards become hard-coded to a specific channel, and will only connect to hotspots that use the same channel number.
 

guavagirl

Thread Starter
Joined
May 21, 2007
Messages
7
Thanks JohnWill and Gurutech! I'll check out both of those things tonight (my computer is at home so can't do it now...). How would I check the channel of the wireless card and turn that to auto??

Thanks, again!
 
Joined
Apr 23, 2004
Messages
2,960
Go to the General tab (as shown in JohnWill's picture), and you will see a button next to or just underneath the wireless adapter.

Click this button (labeled "Configure"), and then go to the Advanced tab. On the left side, look for something called "Channel" or it may be "IBSS Wireless Channel". Highlight this, and then on the right side, it will list the channel you are currently using. If it already says "Auto", then try changing it to something else, save the settings, then go back and change it back to "Auto".

If "Auto" (or something similar) isn't listed as an option, then you may need to go to the Dell website (http://support.dell.com) to download the latest drivers.
 

guavagirl

Thread Starter
Joined
May 21, 2007
Messages
7
Well, I tried both things, but unfortunately, my screen didn't look the same as your screenshots, so I just had to do my best. As for the channel, I found something that said "802.11 only" and the other option was "802.11/auto." I changed it to the latter, but it still isn't connecting. I've tried posting at Dell, but no one there seems to know either. Looks like I might have to pay to have someone come take a look...

Thanks for your help.
 
Joined
Oct 20, 2003
Messages
1,625
At the risk of staing the obvious ... you've encryption into account?
Are you configured to use encryption and the public hotpsots are not using encryption and you've getting a mis-match?
 

guavagirl

Thread Starter
Joined
May 21, 2007
Messages
7
OK, at the risk of sounding like an idiot... huh? I'm assuming you're asking whether at home I need some kind of security code and everywhere else I don't, but I have my computer set up to ask for a security code? If that is what you mean, then the answer is no. My wireless at home is not encrypted, nor are the hotspots I'm going to.... Thanks for the suggestion! (and if that's not what you meant, could you explain, please?) :)
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
80,623
My warped mind says there are two situations that could fit your symptoms. You've eliminated my first guess (static IP) by saying you are using 'obtain IP auto.' The other thing is a firewall (Internet Security). You have Norton or McAfee or something that is configured to allow your home LAN (e.g., maybe 192.168.1.x) access but not other IP addresses.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,425
While attempting to connect to the WiFi hotspot, let's see this:

Start, Run, CMD to open a command prompt:

Type the following command:

IPCONFIG /ALL

Right click in the command window and choose Select All, then hit Enter.
Paste the results in a message here.
 

guavagirl

Thread Starter
Joined
May 21, 2007
Messages
7
This is what I got:

Microsoft Windows XP [Version 5.1.2600]

(C) Copyright 1985-2001 Microsoft Corp.



Windows IP Configuration



Host Name . . . . . . . . . . . . : Russ

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Hybrid

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No



Ethernet adapter Local Area Connection:



Media State . . . . . . . . . . . : Media disconnected

Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Cont

roller

Physical Address. . . . . . . . . : 00-18-8B-BA-49-50



Ethernet adapter Wireless Network Connection:



Media State . . . . . . . . . . . : Media disconnected

Description . . . . . . . . . . . : Dell Wireless 1390 WLAN Mini-Card

Physical Address. . . . . . . . . : 00-1A-92-52-F4-98



Ethernet adapter Local Area Connection 2:



Media State . . . . . . . . . . . : Media disconnected

Description . . . . . . . . . . . : Bluetooth Personal Area Network from

TOSHIBA

Physical Address. . . . . . . . . : 00-16-41-CD-95-2C

Does that help at all???
 
Joined
May 22, 2005
Messages
72
Are you using DELL connection software or XP connection? If you use XP it will prompt you that it has detected another wi-fi access you then have to choose that connection. This should appear down near your system tray clock. If it doesn't then you don't have the show icon feature for your wireless connection turned on. Small features like this well aid you. So if you can connect at home okay then going on a business trip using the hotel wi-fi or airport hotspot you should be able to connect.
 

guavagirl

Thread Starter
Joined
May 21, 2007
Messages
7
Apparently, on the Dell D620, when you use your battery the system turns off the Internal Network card to conserve power. It was simply a metter of making sure the Internal Network Card was selected to "Always activate on battery." Who knew? Figures it was so simple. Than you all for your help.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,425
You can mark your own threads solved using the thread tools at the upper right of the screen.© :)
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top