1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: desktop.ini file not working properly

Discussion in 'Windows XP' started by worldchamp, Dec 21, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. worldchamp

    worldchamp Thread Starter

    Joined:
    Feb 26, 2012
    Messages:
    14
    Recently, I customized some of my folders backgrounds, font colors etc. with the desktop.ini files. However, I came to know that it works only for a few folders and not everyone. e.g.: When I copy the desktop.ini file from one folder to say 5 other folders, it works only for 2-3 of them and not all of them. I tried changing the attributed of folders to read only etc. but nothing happened. Moreover, I'm the administrator of the pc. Kindly shed some light as to why this is happening. Really confused with it.
     
  2. throoper

    throoper Trusted Advisor (deceased)

    Joined:
    Jan 20, 2007
    Messages:
    5,176
    The desktop.ini should have the attrib of system, and the folder containing it also needs to have the attrib of system for it to have an effect.
    The folders it's working in for you have likely been previously customized and already been changed to a system attribute.

    Simplest way to do what you want is to simply change the icon of the folder using Properties>Change icon. That will create a desktop.ini in the folder and set the system attribute.
    Open the desktop.ini and copy>paste what you want into it.
    Basically, let Windows do the work.

    Alternatively, you can set the system attrib using Command Prompt.
    Start>Run>type cmd.exe>OK.
    At the prompt, type attrib +s "full path to folder" and press Enter.
    The "full path to folder" would be, for example, C:\Documents and Settings\username\My Documents\foldername, wrapped in quotes.
     
  3. worldchamp

    worldchamp Thread Starter

    Joined:
    Feb 26, 2012
    Messages:
    14
    thanks a lot throoper!!! it works now. However, is it possible to make a newly and manually created desktop.ini file to automatically (or by default) have the system attributes? Moreover, is it possible to provide the desktop.ini file to possess the system attributes (I mean only the desktop.ini file not the folder)? just out of curiosity.
     
  4. throoper

    throoper Trusted Advisor (deceased)

    Joined:
    Jan 20, 2007
    Messages:
    5,176
    It's the folder that NEEDS the system attribute, not the Desktop.ini.
    You can create a new text file and rename it to Desktop.ini and it should work in any folder with the system attribute.
    The only reason to make the Desktop.ini a hidden system file is to "super hide" it, so you don't have the "ghost" file image if you normally have hidden files and folders showing (it will only show if you've unchecked "Hide protected operating system files" in the Folder Options).
     
  5. worldchamp

    worldchamp Thread Starter

    Joined:
    Feb 26, 2012
    Messages:
    14
    hmmm... got it. thanks a lot for the help throoper!!!
    btw, I can't find any "thanks" or "rep-up" button here for your profile.
    This forum needs to provide them soon. :)
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Solved desktop file
  1. Buffalo19
    Replies:
    1
    Views:
    947
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1081835

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice