Solved: DHCP error, can't connect nerwork

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

hrtbob

Thread Starter
Joined
Jun 24, 2003
Messages
101
Hey all,

I have a simple network at home using winxp pro on both comps. I wish to use simple file sharing but am unable to do so. I have automatically configured IP addresses for both comps, and am able to ping using these ip addresses but cannot ping by comp name. both comps have addresses starting with 169.254.x.x indicating that the dhcp cannot issue a proper address, however when trying to release and/or renew the computer says that it has timed out before the request can be completed.

I have tried uninstalling the devices, rebooting and then reinstalling but the wizard falls short at the end claiming an error has occured.

The error according to admin tools is in the system section saying-

The device, \Device\Scsi\viamraid1, did not respond within the timeout period.

look forward to some responses! ...please!!!

regards,
Hrtbob
 

JonathanAnon

Banned
Joined
Dec 17, 2004
Messages
531
is meant to be handling DHCP, is it the router or do you have a server.

Have you checked (or rebooted) the device that DHCP is working on the device.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,429
If you don't have a broadband router, or some other server device, I suggest a manual configuration.

machine 1
---------
IP: 192.168.0.2
Subnet Mask 255.255.255.0

machine 2
---------
IP: 192.168.0.3
Subnet Mask 255.255.255.0

Configure file/print sharing and share at least one drive/folder on the machine you wish to connect to.
 

hrtbob

Thread Starter
Joined
Jun 24, 2003
Messages
101
g'day folks, thanks for the replies.

this is indeed a very simple network requirement. I have no need to share an internet requirement as i have dial up internet using....wait for it...a 33k modem!!!!! don't be too alarmed folks, this is my choice, Its my protest for broadband internet at home--> hopefully the slowness will prompt a reaction!

so there is no router, no server. just two machines with cable in between.

JohnWill, I am trying you idea tonight fingers crossed it works.
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
81,164
You were able to ping by the Automatic Private IP Addresses (APIPA) so that wasn't your problem. However, JohnWill's static IPs will have you connecting faster and more reliably.

Check that your computer names do not contain blanks--especially not leading and not trailing--or other "funny" characters.
 
Joined
Jun 29, 2005
Messages
17
First of all, since you are not using a hub or router to connect the pc i hope you are using a cross over cable to connect between the PC.
Second use the ip configuration that JohnWill stated above.
Make sure under LAN properties you have file and printer sharing checked.
Third goes to the drive/folder to share ( let say the 1st pc drive c ) and right click on it and click sharing . Under sharing put a check by "share this folder" , under share name give it a name like "c" for drive c ect. Then click apply.
After that, goes to the other computer and go to Start then Run. Type in : ip address ,which is "192.168.0.2\c" and you should be able to see that folder.Hope this help :).

PS: if you want to map it permanently let me know.
 

hrtbob

Thread Starter
Joined
Jun 24, 2003
Messages
101
ok, ive manually set the ip adresses and have enabled print and file sharing on both computers. They are set to the workstation 'MSHOME' and the local drives are shared with the name 'c'. I am able to ping the IP address, but once again cannot ping via computer name, these names are assigned with a single word and no spacing. still no luck...eventually i would like to map them permanently for ease of access.

cheers,
Hrtbob
 
Joined
Jun 29, 2005
Messages
17
Sry i mistype the command line to access the share drive
I should be : \\192.168.0.2\c
type that in the run box

or if you want to map the drive you can right click my computer then go to map network drive. In the drive box select the letter you want to name it . the on the folder box type in : \\192.168.0.2\c and put a check box by reconnnect on log on.

PS: pinging with name doesn't always come back with the right result. the most reliable way is just to ping the ip address of the device.
Hope that help
 

hrtbob

Thread Starter
Joined
Jun 24, 2003
Messages
101
"the network path was not found" is the error i come up with when attempting to ping the share drive. When mapping the drive it cannot find it either, and using the browse button it can locate up to mshome but cannot access anything further. I know i'm out of ideas!

cheers, hrtbob
 

hrtbob

Thread Starter
Joined
Jun 24, 2003
Messages
101
hi again, another update.
i have now mapped a drive from my second computer to my primary computer but cant map the other way around. I managed to get some network 'flow' by going into services and setting 'computer browser' to autorun rather than its initial setting of disabled for both computers.

so to summarise, one computer can perfectly transfer data to and from but the other cannot!

ciao,Hrtbob
 
Joined
Jun 29, 2005
Messages
17
did you do the exact same thing for the other comp ? like sharing the drive and give it a name. then goes to your firsst comp and type in : \\192.168.0.3\c
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,429
All machines are must be in the same subnet, i.e. 192.168.0.x where x is any number. The subnet mask should be 255.255.255.0 for most small networks.

Turn off any firewalls for debugging. If the firewall is the problem, you'll have to configure it to allow access to "trusted zone" addresses. Note that some firewalls must be completely uninstalled to stop them from affecting your networking.

PING each computer by IP address, and if successful, PING by name. You can obtain the IP address of a computer by opening a command prompt (DOS window) and typing IPCONFIG. This should work for any Windows version.

All computers should be in the same workgroup for computer browsing to function properly. File & Print Sharing has to be enabled on any computer you wish to share files or printers from. You also need to actually share the resource in question from My Computer, right click on the drive/printer/folder, and select sharing.

If you encounter difficulties accessing computers that are visible in Network Neighborhood, make sure the computer being accessed has an account with the same name/password as the system connecting to it uses to login.

While the default NetBIOS setting is correct for normal network configurations, it's possible for it to be altered, and it costs nothing to make sure it's correct. NETBIOS over TCP/IP must be enabled for normal network browsing.
 

hrtbob

Thread Starter
Joined
Jun 24, 2003
Messages
101
g'day,

Ok, JohnWill; here is a checklist of all the things you suggest are required.

must have same subnet: done, manually configured.
subnet masks same, 255.255.255.0: done
firewalls: done, programs disabled as is internet firewall for xp

ping by address: successful
ping by name: UNsuccessful

must have same workgroup: done, both in MSHOME workgroup
file & printer sharing: enabled for both

sharing of drives: enabled, for simplicity local drives are labelled 'c' on each computer

netbios must be enabled: done

-->what do you mean by both computers must have a same account with user/password to login??

do you mean for example, that there should be a user on the welcome screen called 'bob' for each computer and that the password for 'bob' is 1234 on each computer? do you then have to login under 'bob' everytime you wish to use the network??

i'm bewildered at the moment!
cheers,
Hrtbob.
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
81,164
If you're really using Simple File Sharing you shouldn't need the same userid/passwd on both machines; of course, it doesn't hurt.

Now that you have the Computer Browser service running on both machines, it may be just a matter for the two PCs to "learn" about each other. I suggest on each machine:
1. Restart.
2. From the top part of My Network Places click on the Search symbol and search for the other computer.
3. From My Network Places click on "view workgroup computers."

You may have to repeat steps 1-3. Good chance your workgroup will be working fine by now (including ping by name).
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,429
Checklist for networking Windows Machines with TCP/IP
-----------------------------------------------------
- PCs which are not XP must have TCP/IP installed.
- Each PC must have a unique computer name.
- Each PC must have a network share defined.
- ALL NICS must be on the same subnet (e.g. IP 192.168.0.* subnet mask 255.255.255.0).
- XP PCs must have Netbios over TCP/IP enabled (only essential for XP to talk to W9X PCs).
- MS Client and file & printer sharing must be enabled on each machine.
- All NICs must have their node type = anything except p-node (peer to peer, or point-point).
* To check, open a command prompt and type IPCONFIG /ALL.
- XP's ICF firewall is permanently disabled. (Only necessary for pre XP SP2).
- All 3rd party firewalls are disabled, uninstalled and deleted (until connection is working).
- PCs have the same workgroup (helps, but not essential for XP/2K, necessary for 9X/ME).

Allow 15 mins after rebooting a PC for that PC to appear in the workgroup, or
for it to see all other PCs. Or you can search for the PC by its computer name.


Additional things to check if you still have problems:
-----------------------------------------------------
- Check your Services are Started on all PCs: Workstation, Server, TCP/IP Netbios helper, Computer Browser.
- XP gives access to its shares via the Net Guest Account. (Note, not the same as the local guest account in user accounts which should be off). Net Guest Account is enabled by default in XP, but to check it, open a command prompt and type: NET USER GUEST
Should return a line with 'Account active yes'.


Check XP Security policies:
--------------------------
- Access this computer from the network: add guest
- Deny logon locally: remove guest
- Network access:Sharing and security model... -> Guest only
- Deny access to this computer from the network-> check Guest is not here.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top