1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: DHCP & HUAWEI Echolife HG521 router

Discussion in 'Networking' started by ShaggyDogg, Jun 4, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. ShaggyDogg

    ShaggyDogg Thread Starter

    Joined:
    Jun 4, 2011
    Messages:
    3
    Hi,
    I have a HUAWEI Echolife HG521 router and just set up a home Windows Server 2008r2 and configured DHCP on the server.
    After trying multiple variations of setting, switching on and off almost every operation on the router, I cannot seem to enable the network clients to obtain addressing from the DHCP server. All leases are still with the router and none showing on the server.

    The HUAWEI router configurations are:

    Basic\LAN:
    LAN IP: 192.168.1.1

    DHCP Server:
    DHCP enabled: Yes
    Start IP: 192.168.1.10
    End IP: 192.168.1.254
    Lease: 8day (default)
    Domain: MyDomain.net
    Primary DNS: 192.168.1.2 (my 1DNS server)
    Secondary DNS: 192.168.1.3 (my 2DNS server)

    DHCP Option Pool:
    Device: STB
    DHCP Option Pool enabled: false
    Option60: vnl_stb
    Start IP: 192.168.1.10
    End IP: 192.168.1.254
    DHCP relay: Enabled
    Operation: Set


    The DHCP service on the server is configured correctly and running.

    I've tried:
    1. Disabling DHCP on the router altogether, but nothing seems to relay to the server.
    2. Changing the LAN IP to 192.168.1.2 (hoping to route LAN requests to the server) but this just seems to result in a router/server IP conflict.

    Can anyone please shed any light on this? Feel free to ask questions if more info is needed.

    Many thanks
     
  2. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    There should be a setting on the router for DHCP forwarding and then a place to set the address of the DHCP server. Of course, DHCP should be disabled on the router.
     
  3. ShaggyDogg

    ShaggyDogg Thread Starter

    Joined:
    Jun 4, 2011
    Messages:
    3
    Thanks, and that's the sort of thing I've been looking for on the router but haven't found it that straight forward. Here's a screen shot of the router dhcp config page..

    [​IMG]

    Here are sceen shots of all other config pages >-- http://www.pcwintech.com/screenshots-huawei-echolife-hg521-huawei-firmware

    I've found very limited info & help guides for this particular router online.
     
  4. taliadon

    taliadon

    Joined:
    Jun 13, 2011
    Messages:
    1
    Not sure about the HG521, but the HG532 has a "DHCP port transparent transmission" option listed under "Basic->LAN->DHCP Option"; please see linked image.

    [​IMG]

    Enabling this for all LAN-side networks, as depicted above, should ensure that all DHCP requests reach your server.

    Hope this helps, Lee.
     
  5. ShaggyDogg

    ShaggyDogg Thread Starter

    Joined:
    Jun 4, 2011
    Messages:
    3
    Thanks Lee. The HG521 doesn't have that option. After some more research drawing a blank I've concluded it isn't possible.
    So, I'll mark this thread as solved, but if anyone reading does know of a way, please get in contact.
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1000484