1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Drivers not being signed - "Code52"

Discussion in 'Windows 7' started by Greg8806, Jan 4, 2013.

Thread Status:
Not open for further replies.
  1. Greg8806

    Greg8806 Thread Starter

    Joined:
    Jan 4, 2013
    Messages:
    2
    Hello all, I've been up for the most part of the night trying to solve my problem with a few of my drivers not working.
    Most of the time I can figure this stuff out on my own, but this one has me stumped. I will provide pictures of the drivers that are not working, and have the "Code52" error.

    The things that I have tried to do:

    1. Ran sigverif.exe - the files was not signed
    2. Tried to rename the files and re-install.
    3. Booted into Advanced Boot Options and disabled driver signing.
    4. Started in safe mode and installed the drivers, but after reboot I had the "Code52" again.
    5. Ran a full system scan with Trend Micro.

    I could be leaving out something, but I been all night trying to get this problem fixed. Any help would be nice, but I really don't want to format unless that is the only way I can get this fixed.

    PC Specs:

    OS Version: Microsoft Windows 7 Home Premium, Service Pack 1, 64 bit
    Processor: Intel(R) Core(TM) i7 CPU 950 @ 3.07GHz, Intel64 Family 6 Model 26 Stepping 5
    Processor Count: 8
    RAM: 12272 Mb
    Graphics Card: NVIDIA GeForce GTX 560, -2048 Mb
    Hard Drives: C: Total - 305021 MB, Free - 104231 MB; D: Total - 304921 MB, Free - 89955 MB;
    Motherboard: MSI, Eclipse SLI (MS-7520)
    Antivirus: Trend Micro Titanium Maximum Security, Updated: Yes, On-Demand Scanner: Enabled
     

    Attached Files:

  2. Greg8806

    Greg8806 Thread Starter

    Joined:
    Jan 4, 2013
    Messages:
    2
    Well it looks like I have found a fix for the error "Code52". It looks like if you go into the boot menu, and turn off the driver signature enforcement it will work. I thought I was doing this correctly before, but I wasn't. I could not get my Advanced Boot Menu to pull up while starting my PC. I went around that and pulled up msconfig. The only thing wrong with using msconfig to open the menu is, it will start the computer in safemode. In this case, it didn't work. Safemode allowed me to install/sign the drivers but would not stay installed/signed once I rebooted. I tried once more to spam the f8 button until it put me into the menu, which after a few tries it did. Once I got into the menu I then chose the driver signature enforcement option. I launched windows and bingo, I have sound again. Although this may be a temporary fix, i'm not sure yet. I may have to disable driver signature every time I launch, but if it saves me from a format I can live with that. Hope this helps someone down the road.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1083688

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice