Solved: DVD not working

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

xandin4

Thread Starter
Joined
May 28, 2008
Messages
23
I have a Dell Vostro 220 w/ TSST TS-H653F CD/DVD+-RW. It will not read Cd's or DVd's at this point in time. It used to read CD's, and I'm fairly sure it used to read DVD's (though I'm not 100% certain about that). I have uninstalled the device and tried to reinstall it to no avail. I get "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)" in the device properties window.
I have also tried downloading a new driver from Dell's website to no avail. None of them work, none will recognize the hardware. I just pulled the drive from the computer to verify that it is the correct drive, and it is what it says it is.
I am running XP, nothing special about this system.
Any insight would be most welcome!
 

xandin4

Thread Starter
Joined
May 28, 2008
Messages
23
Oh, and it does have the yellow exclamation point in the device manager. :-(
 
Joined
Dec 28, 2010
Messages
7
Make sure that it's connected in correctly. Check for loose connections, etc...
Do the discs spin up/does the drive door open?
If not, then the drive is probably knackered.

What you could try is if you have a Windows setup CD, insert it in the drive, then reboot the computer and press F12 constantly until the boot menu comes up. Try booting from the disc. If it doesn't, then the drive is probably knackered.
 

xandin4

Thread Starter
Joined
May 28, 2008
Messages
23
Great idea! Thanks! I swapped it out with a DVD Drive that I know to work. It still won't install it, and I'm having the same problems with this one. :-(
I read elsewhere to uninstall XP SP3, and have tried doing that, however there is no listing of SP3 in the uninstall software list, nor is the folder for manual uninstall showing up. However, my computer still says that it is indeed SP3.
GRRRRRR!!!!!!!!!
 

xandin4

Thread Starter
Joined
May 28, 2008
Messages
23
Oh...and there are no loose connections, everything is plugged in properly, and nothing spins up when I put a disc in.
 
Joined
Dec 28, 2010
Messages
7
I don't know what they are talking about by deleting SP3, as I don't think you can. There may be a problem with the software side of things if you put a new drive in and it wouldn't work either. Did you try booting from a Windows setup CD from the BIOS screen? It is either F12 or F2 you have to press to get the boot screen up. As soon as you turn your computer on, keep pressing F2 until the boot menu comes up. Put the disc in the drive and select with the arrow keys the "boot from CD/DVD" and press enter. It may be called your actual drive name, but I'm not sure. If it spins up, the drive is fine. If it doesn't, then we have a bigger problem. Did you mean the disc doesn't spin up when you are in Windows, or at the BIOS screen?
 

xandin4

Thread Starter
Joined
May 28, 2008
Messages
23
It saw and read the CD from boot up. But still will not recognize anything in the CD drive once booted up. It sees the drive itself, just won't do anything with it, and still says there's a problem with the driver.
I'm fairly sure it's a software issue, but I cannot for the life of me get the bleeping driver installed.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top