Solved: Error: 1607

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

leslie56

Thread Starter
Joined
Aug 26, 2008
Messages
34
I have just reinstalled the OS on my Dell Dimension 8400 and I am trying to install the drivers. I was able to install the Desktop System Software drive successfully, however when I attempt to install any of the other drivers I get the following error msg from all of them: 1607: Unable to install InstallShield Scripting Runtime.

I Googled the error msg for a solution but could not find anything that worked. Any suggestions?

Here is a picture of my proble drivers:
:confused:

Thanks
 

leslie56

Thread Starter
Joined
Aug 26, 2008
Messages
34
Thank you but that link is not good, when I click on it I get a page that says
"Oops! Internet Explorer could not connect to consumerdocs.installshield.com"

So, then I tried it with Google Chrome and unfortunately I got the same thing. :confused: Is there another link possibly?
 
Joined
Oct 20, 2011
Messages
684
Thank you but that link is not good, when I click on it I get a page that says
"Oops! Internet Explorer could not connect to consumerdocs.installshield.com"

So, then I tried it with Google Chrome and unfortunately I got the same thing. :confused: Is there another link possibly?

The link on the microsoft website http://support.microsoft.com/kb/888019 is the one I gave you: " http://consumerdocs.installshield.com/selfservice/viewContent.do?externalId=Q108322&sliceId=1
and as you said it's a broken link which is odd considering the source.. I'll get another link for you. Wonder why the microsoft website provided a broken link- it worked when I posted Let me check into it..
 
Joined
Oct 20, 2011
Messages
684
Okay First check whether Windows Installer engine is functioning.

Click Start > Run > Then type: cmd

At the command prompt, type MSIExec and press Enter. MSI refers to the Windows Installer. If you see an error message, note down the error.

Now try to install or uninstall the program again. If the problem persists, go to the next fix.

Check that Windows Installer service is not disabled.

Click Start > Run > and type: service.msc
The Services window is opened. Right-click on ‘Windows Installer’ service, then click ‘Start’. The service needs to start without any errors.
If the installer version doesn’t show as version 4.5, download the latest version at http://support.microsoft.com/kb/942288/

Now try to install or reinstall your program again. If it still persists, try the next fix.

Reregister the installer engine.Click Start > Run > Type: cmd

At the command prompt, first type MSIExec / unregister, then press Enter and type MSIExec / regserver. Now try to install or reinstall your program/drivers again.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top